blob: 4af47fedeb77a565dfbd393e55e9d264f832a05b [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "libsecret is a library for storing and retrieving passwords and other secrets"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=23c2a5e0106b99d75238986559bb5fc6"
4
5inherit gnomebase gtk-doc vala gobject-introspection manpages
6
7DEPENDS += "glib-2.0 libgcrypt gettext-native"
8
9PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native"
10
11SRC_URI[archive.md5sum] = "fee403988442f497f3c1dfe7b128869c"
12SRC_URI[archive.sha256sum] = "3bfa889d260e0dbabcf5b9967f2aae12edcd2ddc9adc365de7a5cc840c311d15"
13
14# http://errors.yoctoproject.org/Errors/Details/20228/
15ARM_INSTRUCTION_SET_armv4 = "arm"
16ARM_INSTRUCTION_SET_armv5 = "arm"
17ARM_INSTRUCTION_SET_armv6 = "arm"
18
19# vapigen.m4 bundled with the tarball does not yet have our cross-compilation fixes
20do_configure_prepend() {
21 rm -f ${S}/build/m4/vapigen.m4
22}