blob: 048aaf44133b261162239767ec6ae55c04433c1f [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Python bindings for GStreamer 1.0"
2HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
3SECTION = "multimedia"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
7
8SRC_URI = "http://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
Brad Bishopa5c52ff2018-11-23 10:55:50 +13009SRC_URI[md5sum] = "d4c0e3915f547feef49208ee08981e5a"
10SRC_URI[sha256sum] = "d0fdb24f93b6d889f309d2f526b8ea9577e0084ff0a62b4623ef1aed52e85a1b"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011
12DEPENDS = "gstreamer1.0 python3-pygobject"
13RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject"
14
15PNREAL = "gst-python"
16
17S = "${WORKDIR}/${PNREAL}-${PV}"
18
Brad Bishopc342db32019-05-15 21:57:59 -040019# gobject-introspection is mandatory and cannot be configured
20REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
21UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection"
22
23inherit autotools pkgconfig distutils3-base upstream-version-is-even gobject-introspection distro_features_check
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024
25do_install_append() {
26 # gstpythonplugin hardcodes the location of the libpython from the build
27 # workspace and then fails at runtime. We can override it using
28 # --with-libpython-dir=${libdir}, but it still fails because it looks for a
29 # symlinked library ending in .so instead of the actually library with
30 # LIBNAME.so.MAJOR.MINOR. Although we could patch the code to use the path
31 # we want, it will break again if the library version ever changes. We need
32 # to think about the best way of handling this and possibly consult
33 # upstream.
34 #
35 # Note that this particular find line is taken from the Debian packaging for
36 # gst-python1.0.
37 find "${D}" \
38 -name '*.pyc' -o \
39 -name '*.pyo' -o \
40 -name '*.la' -o \
41 -name 'libgstpythonplugin*' \
42 -delete
43}