Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Shadow utils requirements for useradd.bbclass" |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 2 | HOMEPAGE = "http://github.com/shadow-maint/shadow" |
| 3 | BUGTRACKER = "http://github.com/shadow-maint/shadow/issues" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 4 | SECTION = "base utils" |
| 5 | LICENSE = "BSD | Artistic-1.0" |
| 6 | LIC_FILES_CHKSUM = "file://login.defs_shadow-sysroot;md5=25e2f2de4dfc8f966ac5cdfce45cd7d5" |
| 7 | |
| 8 | DEPENDS = "base-passwd" |
| 9 | |
| 10 | PR = "r3" |
| 11 | |
| 12 | # The sole purpose of this recipe is to provide the /etc/login.defs |
| 13 | # file for the target sysroot - needed so the shadow-native utilities |
| 14 | # can add custom users/groups for recipes that use inherit useradd. |
| 15 | SRC_URI = "file://login.defs_shadow-sysroot" |
| 16 | |
| 17 | SRC_URI[md5sum] = "b8608d8294ac88974f27b20f991c0e79" |
| 18 | SRC_URI[sha256sum] = "633f5bb4ea0c88c55f3642c97f9d25cbef74f82e0b4cf8d54e7ad6f9f9caa778" |
| 19 | |
| 20 | S = "${WORKDIR}" |
| 21 | |
| 22 | do_install() { |
| 23 | install -d ${D}${sysconfdir} |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 24 | install -p -m 644 ${S}/login.defs_shadow-sysroot ${D}${sysconfdir}/login.defs |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 25 | } |
| 26 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 27 | SYSROOT_DIRS += "${sysconfdir}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 28 | |
| 29 | # don't create any packages |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 30 | # otherwise: dbus-dev depends on shadow-sysroot-dev which depends on shadow-sysroot |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 31 | # and this has another copy of /etc/login.defs already provided by shadow |
| 32 | PACKAGES = "" |