Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "interface to seccomp filtering mechanism" |
| 2 | DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp." |
| 3 | SECTION = "security" |
| 4 | LICENSE = "LGPL-2.1" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f" |
| 6 | |
Andrew Geissler | b2fe863 | 2020-08-21 15:57:21 -0500 | [diff] [blame] | 7 | DEPENDS += "gperf-native" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 8 | |
Andrew Geissler | b2fe863 | 2020-08-21 15:57:21 -0500 | [diff] [blame] | 9 | SRCREV = "f13f58efc690493fe7aa69f54cb52a118f3769c1" |
| 10 | |
| 11 | SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.5 \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 12 | file://run-ptest \ |
Andrew Geissler | b2fe863 | 2020-08-21 15:57:21 -0500 | [diff] [blame] | 13 | file://fix-mips-build-failure.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 14 | " |
| 15 | |
Andrew Geissler | b2fe863 | 2020-08-21 15:57:21 -0500 | [diff] [blame] | 16 | COMPATIBLE_HOST_riscv32 = "null" |
| 17 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 18 | S = "${WORKDIR}/git" |
| 19 | |
| 20 | inherit autotools-brokensep pkgconfig ptest |
| 21 | |
| 22 | PACKAGECONFIG ??= "" |
Andrew Geissler | b2fe863 | 2020-08-21 15:57:21 -0500 | [diff] [blame] | 23 | PACKAGECONFIG[python] = "--enable-python, --disable-python, python3" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 24 | |
Brad Bishop | 1fdf4aa | 2019-09-09 14:56:41 -0400 | [diff] [blame] | 25 | DISABLE_STATIC = "" |
| 26 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 27 | do_compile_ptest() { |
| 28 | oe_runmake -C tests check-build |
| 29 | } |
| 30 | |
| 31 | do_install_ptest() { |
| 32 | install -d ${D}${PTEST_PATH}/tests |
| 33 | install -d ${D}${PTEST_PATH}/tools |
| 34 | for file in $(find tests/* -executable -type f); do |
| 35 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests |
| 36 | done |
| 37 | for file in $(find tests/*.tests -type f); do |
| 38 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests |
| 39 | done |
| 40 | for file in $(find tools/* -executable -type f); do |
| 41 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools |
| 42 | done |
| 43 | } |
| 44 | |
| 45 | FILES_${PN} = "${bindir} ${libdir}/${BPN}.so*" |
| 46 | FILES_${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug" |
| 47 | |
| 48 | RDEPENDS_${PN}-ptest = "bash" |