Andrew Geissler | 475cb72 | 2020-07-10 16:00:51 -0500 | [diff] [blame] | 1 | # Baremetal image class |
| 2 | # |
| 3 | # This class is meant to be inherited by recipes for baremetal/RTOS applications |
| 4 | # It contains code that would be used by all of them, every recipe just needs to |
| 5 | # override certain variables. |
| 6 | # |
| 7 | # For scalability purposes, code within this class focuses on the "image" wiring |
| 8 | # to satisfy the OpenEmbedded image creation and testing infrastructure. |
| 9 | # |
| 10 | # See meta-skeleton for a working example. |
| 11 | |
| 12 | |
| 13 | # Toolchain should be baremetal or newlib based. |
| 14 | # TCLIBC="baremetal" or TCLIBC="newlib" |
| 15 | COMPATIBLE_HOST_libc-musl_class-target = "null" |
| 16 | COMPATIBLE_HOST_libc-glibc_class-target = "null" |
| 17 | |
| 18 | |
| 19 | inherit rootfs-postcommands |
| 20 | |
| 21 | # Set some defaults, but these should be overriden by each recipe if required |
| 22 | IMGDEPLOYDIR ?= "${WORKDIR}/deploy-${PN}-image-complete" |
| 23 | BAREMETAL_BINNAME ?= "hello_baremetal_${MACHINE}" |
| 24 | IMAGE_LINK_NAME ?= "baremetal-helloworld-image-${MACHINE}" |
| 25 | IMAGE_NAME_SUFFIX ?= "" |
| 26 | |
| 27 | do_rootfs[dirs] = "${IMGDEPLOYDIR} ${DEPLOY_DIR_IMAGE}" |
| 28 | |
| 29 | do_image(){ |
| 30 | install ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.bin ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.bin |
| 31 | install ${D}/${base_libdir}/firmware/${BAREMETAL_BINNAME}.elf ${IMGDEPLOYDIR}/${IMAGE_LINK_NAME}.elf |
| 32 | } |
| 33 | |
| 34 | do_image_complete(){ |
| 35 | : |
| 36 | } |
| 37 | |
| 38 | python do_rootfs(){ |
| 39 | from oe.utils import execute_pre_post_process |
| 40 | from pathlib import Path |
| 41 | |
| 42 | # Write empty manifest file to satisfy test infrastructure |
| 43 | deploy_dir = d.getVar('IMGDEPLOYDIR') |
| 44 | link_name = d.getVar('IMAGE_LINK_NAME') |
| 45 | manifest_name = d.getVar('IMAGE_MANIFEST') |
| 46 | |
| 47 | Path(manifest_name).touch() |
| 48 | if os.path.exists(manifest_name) and link_name: |
| 49 | manifest_link = deploy_dir + "/" + link_name + ".manifest" |
| 50 | if os.path.lexists(manifest_link): |
| 51 | os.remove(manifest_link) |
| 52 | os.symlink(os.path.basename(manifest_name), manifest_link) |
| 53 | execute_pre_post_process(d, d.getVar('ROOTFS_POSTPROCESS_COMMAND')) |
| 54 | } |
| 55 | |
| 56 | |
| 57 | # Assure binaries, manifest and qemubootconf are populated on DEPLOY_DIR_IMAGE |
| 58 | do_image_complete[dirs] = "${TOPDIR}" |
| 59 | do_image_complete[umask] = "022" |
| 60 | SSTATETASKS += "do_image_complete" |
| 61 | SSTATE_SKIP_CREATION_task-image-complete = '1' |
| 62 | do_image_complete[sstate-inputdirs] = "${IMGDEPLOYDIR}" |
| 63 | do_image_complete[sstate-outputdirs] = "${DEPLOY_DIR_IMAGE}" |
| 64 | do_image_complete[stamp-extra-info] = "${MACHINE_ARCH}" |
| 65 | addtask do_image_complete after do_image before do_build |
| 66 | |
| 67 | python do_image_complete_setscene () { |
| 68 | sstate_setscene(d) |
| 69 | } |
| 70 | addtask do_image_complete_setscene |
| 71 | |
| 72 | # QEMU generic Baremetal/RTOS parameters |
| 73 | QB_DEFAULT_KERNEL ?= "${IMAGE_LINK_NAME}.bin" |
| 74 | QB_MEM ?= "-m 256" |
| 75 | QB_DEFAULT_FSTYPE ?= "bin" |
| 76 | QB_DTB ?= "" |
| 77 | QB_OPT_APPEND = "-nographic" |
| 78 | |
| 79 | # This next part is necessary to trick the build system into thinking |
| 80 | # its building an image recipe so it generates the qemuboot.conf |
| 81 | addtask do_rootfs before do_image after do_install |
| 82 | addtask do_image after do_rootfs before do_image_complete |
| 83 | addtask do_image_complete after do_image before do_build |
| 84 | inherit qemuboot |
| 85 | |
| 86 | # Based on image.bbclass to make sure we build qemu |
| 87 | python(){ |
| 88 | # do_addto_recipe_sysroot doesnt exist for all recipes, but we need it to have |
| 89 | # /usr/bin on recipe-sysroot (qemu) populated |
| 90 | def extraimage_getdepends(task): |
| 91 | deps = "" |
| 92 | for dep in (d.getVar('EXTRA_IMAGEDEPENDS') or "").split(): |
| 93 | # Make sure we only add it for qemu |
| 94 | if 'qemu' in dep: |
| 95 | deps += " %s:%s" % (dep, task) |
| 96 | return deps |
| 97 | d.appendVarFlag('do_image', 'depends', extraimage_getdepends('do_addto_recipe_sysroot')) |
| 98 | d.appendVarFlag('do_image', 'depends', extraimage_getdepends('do_populate_sysroot')) |
| 99 | } |