Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Architecture-dependent configuration for opkg" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 2 | HOMEPAGE = "http://code.google.com/p/opkg/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 3 | LICENSE = "MIT" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 4 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 5 | PR = "r1" |
| 6 | |
| 7 | S = "${WORKDIR}" |
| 8 | |
| 9 | do_compile() { |
| 10 | mkdir -p ${S}/${sysconfdir}/opkg/ |
| 11 | |
| 12 | archconf=${S}/${sysconfdir}/opkg/arch.conf |
| 13 | |
| 14 | rm -f $archconf |
| 15 | ipkgarchs="${ALL_MULTILIB_PACKAGE_ARCHS}" |
| 16 | priority=1 |
| 17 | for arch in $ipkgarchs; do |
| 18 | echo "arch $arch $priority" >> $archconf |
| 19 | priority=$(expr $priority + 5) |
| 20 | done |
| 21 | } |
| 22 | |
| 23 | |
| 24 | do_install () { |
| 25 | install -d ${D}${sysconfdir}/opkg |
| 26 | install -m 0644 ${S}/${sysconfdir}/opkg/* ${D}${sysconfdir}/opkg/ |
| 27 | } |
| 28 | |
| 29 | FILES_${PN} = "${sysconfdir}/opkg/ " |
| 30 | |
| 31 | CONFFILES_${PN} += "${sysconfdir}/opkg/arch.conf" |
| 32 | |
| 33 | RREPLACES_${PN} = "opkg-config-base" |
| 34 | RCONFLICTS_${PN} = "opkg-config-base" |
| 35 | RPROVIDES_${PN} = "opkg-config-base" |