Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | require gmp.inc |
| 2 | |
| 3 | LICENSE = "GPLv2+ | LGPLv3+" |
| 4 | |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| 6 | file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \ |
| 7 | file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 8 | " |
| 9 | |
| 10 | REVISION = "" |
| 11 | SRC_URI = "https://gmplib.org/download/${BPN}/${BP}${REVISION}.tar.bz2 \ |
| 12 | file://amd64.patch \ |
| 13 | file://use-includedir.patch \ |
| 14 | file://0001-Append-the-user-provided-flags-to-the-auto-detected-.patch \ |
| 15 | file://0001-confiure.ac-Believe-the-cflags-from-environment.patch \ |
| 16 | " |
| 17 | SRC_URI[md5sum] = "8ddbb26dc3bd4e2302984debba1406a5" |
| 18 | SRC_URI[sha256sum] = "5275bb04f4863a13516b2f39392ac5e272f5e1bb8057b18aec1c9b79d73d8fb2" |
| 19 | |
| 20 | acpaths = "" |
| 21 | |
| 22 | EXTRA_OECONF += " --enable-cxx=detect" |
| 23 | EXTRA_OECONF_mipsarchr6_append = " --disable-assembly" |
| 24 | |
| 25 | PACKAGES =+ "libgmpxx" |
| 26 | FILES_libgmpxx = "${libdir}/libgmpxx${SOLIBS}" |
| 27 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 28 | do_install_prepend_class-target() { |
| 29 | sed -i \ |
| 30 | -e "s|--sysroot=${STAGING_DIR_HOST}||g" \ |
| 31 | -e "s|${DEBUG_PREFIX_MAP}||g" \ |
| 32 | ${B}/gmp.h |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 33 | } |
| 34 | |
| 35 | SSTATE_SCAN_FILES += "gmp.h" |
| 36 | |
| 37 | # Doesn't compile in MIPS16e mode due to use of hand-written |
| 38 | # assembly |
| 39 | MIPS_INSTRUCTION_SET = "mips" |
| 40 | |
| 41 | BBCLASSEXTEND = "native nativesdk" |