Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | DESCRIPTION = "C implementation of createrepo." |
| 2 | HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki" |
| 3 | |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | |
| 7 | SRC_URI = "git://github.com/rpm-software-management/createrepo_c \ |
| 8 | file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 9 | " |
| 10 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | PV = "0.12.1" |
| 12 | SRCREV = "7744554ddef7c5be2cd7fbcac49c8b24ce60ef88" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm" |
| 17 | DEPENDS_append_class-native = " file-replacement-native" |
| 18 | |
| 19 | inherit cmake pkgconfig bash-completion distutils3-base |
| 20 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 22 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | BBCLASSEXTEND = "native nativesdk" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 24 | |
| 25 | # Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in |
| 26 | do_install_append_class-native() { |
| 27 | create_wrapper ${D}/${bindir}/createrepo_c \ |
| 28 | RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm |
| 29 | } |
| 30 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | do_install_append_class-nativesdk() { |
| 32 | create_wrapper ${D}/${bindir}/createrepo_c \ |
| 33 | RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm |
| 34 | rm -rf ${D}/etc |
| 35 | } |