Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "GTK+2 standard themes" |
| 2 | HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/gnome-themes-standard/" |
| 3 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 4 | SECTION = "x11/gnome" |
| 5 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 6 | LICENSE = "LGPL-2.1-only" |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 8 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 9 | inherit gnomebase gettext gtk-icon-cache upstream-version-is-even features_check |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 10 | |
| 11 | ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}" |
| 12 | |
| 13 | DEPENDS += "intltool-native gtk+" |
| 14 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 15 | # PV is 3.28 not 3.28.0, so the gnomebase SRC_URI isn't right. |
| 16 | SRC_URI = "${GNOME_MIRROR}/${BPN}/${PV}/${BPN}-${PV}.tar.xz;name=archive" |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame] | 17 | SRC_URI[archive.md5sum] = "f9f2c6c521948da427f702372e16f826" |
| 18 | SRC_URI[archive.sha256sum] = "7c4ba0bff001f06d8983cfc105adaac42df1d1267a2591798a780bac557a5819" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 19 | |
| 20 | EXTRA_OECONF = "--disable-gtk3-engine" |
| 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | do_install:append() { |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 23 | # Only building Adwaita, remove highcontrast files |
| 24 | rm -rf ${D}${prefix}/share/themes/HighContrast \ |
| 25 | ${D}${prefix}/share/icons |
| 26 | |
| 27 | # The libtool archive file is unneeded with shared libs on modern Linux |
| 28 | rm -rf ${D}${libdir}/gtk-2.0/2.10.0/engines/libadwaita.la |
| 29 | } |
| 30 | |
| 31 | # There could be gnome-theme-highcontrast as well but that requires |
| 32 | # gtk+3 and includes lots of icons (is also broken with B != S). |
| 33 | PACKAGES += "gnome-theme-adwaita \ |
| 34 | gnome-theme-adwaita-dark \ |
| 35 | " |
| 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | FILES:gnome-theme-adwaita = "${prefix}/share/themes/Adwaita \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 38 | ${libdir}/gtk-2.0/2.10.0/engines/libadwaita.so" |
| 39 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 40 | FILES:gnome-theme-adwaita-dark = "${prefix}/share/themes/Adwaita-dark" |
| 41 | RDEPENDS:gnome-theme-adwaita-dark = "gnome-theme-adwaita" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 42 | |
| 43 | # gnome-themes-standard is empty and doesn't exist |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 44 | RDEPENDS:${PN}-dev = "" |