Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Dominate is a Python library for creating and manipulating HTML documents using an elegant DOM API." |
| 2 | LICENSE = "LGPL-3.0-only" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b52f2d57d10c4f7ee67a7eb9615d5d24" |
| 4 | |
| 5 | SRC_URI[sha256sum] = "520101360892ebf9d0553f67d37e359ff92403d8a1e33814030503088a05da49" |
| 6 | |
| 7 | inherit pypi setuptools3 ptest |
| 8 | |
| 9 | SRC_URI += " \ |
| 10 | file://run-ptest \ |
| 11 | " |
| 12 | |
| 13 | RDEPENDS:${PN}-ptest += " \ |
| 14 | ${PYTHON_PN}-pytest \ |
| 15 | " |
| 16 | |
| 17 | do_install_ptest() { |
| 18 | install -d ${D}${PTEST_PATH}/tests |
| 19 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 20 | } |
| 21 | |
| 22 | RDEPENDS:${PN} += "\ |
| 23 | ${PYTHON_PN}-numbers \ |
| 24 | ${PYTHON_PN}-threading \ |
| 25 | " |