Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Google gRPC" |
| 2 | HOMEPAGE = "http://www.grpc.io/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "Apache-2.0 & BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=731e401b36f8077ae0c134b59be5c906" |
| 6 | |
| 7 | DEPENDS += "${PYTHON_PN}-protobuf" |
| 8 | |
| 9 | SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch" |
| 10 | SRC_URI:append:class-target = " file://ppc-boringssl-support.patch \ |
| 11 | file://boring_ssl.patch \ |
| 12 | file://mips_bigendian.patch \ |
| 13 | file://abseil-ppc-fixes.patch;patchdir=third_party/abseil-cpp \ |
| 14 | " |
| 15 | SRC_URI[sha256sum] = "e6dfc2b6567b1c261739b43d9c59d201c1b89e017afd9e684d85aa7a186c9f7a" |
| 16 | |
| 17 | RDEPENDS:${PN} = "${PYTHON_PN}-protobuf \ |
| 18 | ${PYTHON_PN}-setuptools \ |
| 19 | ${PYTHON_PN}-six \ |
| 20 | " |
| 21 | |
| 22 | inherit setuptools3 |
| 23 | inherit pypi |
| 24 | |
| 25 | CFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE" |
| 26 | |
| 27 | export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY = "1" |
| 28 | |
| 29 | BORING_SSL_PLATFORM:arm = "linux-arm" |
| 30 | BORING_SSL_PLATFORM:x86-64 = "linux-x86_64" |
| 31 | BORING_SSL_PLATFORM ?= "unsupported" |
| 32 | export GRPC_BORING_SSL_PLATFORM = "${BORING_SSL_PLATFORM}" |
| 33 | |
| 34 | BORING_SSL:x86-64 = "1" |
| 35 | BORING_SSL:arm = "1" |
| 36 | BORING_SSL ?= "0" |
| 37 | export GRPC_BUILD_WITH_BORING_SSL_ASM = "${BORING_SSL}" |
| 38 | |
| 39 | GRPC_CFLAGS ?= "" |
| 40 | GRPC_CFLAGS:append:toolchain-clang = " -fvisibility=hidden -fno-wrapv -fno-exceptions" |
| 41 | export GRPC_PYTHON_CFLAGS = "${GRPC_CFLAGS}" |
| 42 | |
| 43 | CLEANBROKEN = "1" |
| 44 | |
| 45 | BBCLASSEXTEND = "native nativesdk" |
| 46 | |
| 47 | CCACHE_DISABLE = "1" |