Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Python interface to PROJ (cartographic projections and coordinate transformations library)" |
| 2 | LICENSE = "MIT" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=dc4bb2668871655e24030dfe8d2a7ce7" |
| 4 | DEPENDS = "python3-cython proj" |
| 5 | DEPENDS:append:class-target = " python3-cython-native proj-native" |
| 6 | |
| 7 | PYPI_PACKAGE = "pyproj" |
| 8 | |
| 9 | inherit pypi setuptools3 |
| 10 | |
| 11 | SRC_URI[sha256sum] = "261eb29b1d55b1eb7f336127344d9b31284d950a9446d1e0d1c2411f7dd8e3ac" |
| 12 | |
| 13 | RDEPENDS:${PN} = "${PYTHON_PN}-certifi proj" |
| 14 | |
| 15 | export PROJ_INCDIR = "${STAGING_INCDIR}" |
| 16 | export PROJ_LIBDIR = "${STAGING_LIBDIR}" |
| 17 | export PROJ_DIR = "${STAGING_BINDIR_NATIVE}/.." |