Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 1 | LINUX_VERSION ?= "5.15.56" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 2 | LINUX_RPI_BRANCH ?= "rpi-5.15.y" |
| 3 | LINUX_RPI_KMETA_BRANCH ?= "yocto-5.15" |
| 4 | |
Patrick Williams | db4c27e | 2022-08-05 08:10:29 -0500 | [diff] [blame] | 5 | SRCREV_machine = "a90998a3e549911234f9f707050858b98b71360f" |
| 6 | SRCREV_meta = "3b1dc2f1fcd869f97901402759b859035984aa7f" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 7 | |
| 8 | KMETA = "kernel-meta" |
| 9 | |
| 10 | SRC_URI = " \ |
| 11 | git://github.com/raspberrypi/linux.git;name=machine;branch=${LINUX_RPI_BRANCH};protocol=https \ |
| 12 | git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${LINUX_RPI_KMETA_BRANCH};destsuffix=${KMETA} \ |
| 13 | file://powersave.cfg \ |
| 14 | file://android-drivers.cfg \ |
| 15 | " |
| 16 | |
| 17 | require linux-raspberrypi.inc |
| 18 | |
| 19 | KERNEL_DTC_FLAGS += "-@ -H epapr" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 20 | |
| 21 | RDEPENDS:${KERNEL_PACKAGE_NAME}:raspberrypi-armv7:append = " ${RASPBERRYPI_v7_KERNEL_PACKAGE_NAME}" |
| 22 | RDEPENDS:${KERNEL_PACKAGE_NAME}-base:raspberrypi-armv7:append = " ${RASPBERRYPI_v7_KERNEL_PACKAGE_NAME}-base" |
| 23 | RDEPENDS:${KERNEL_PACKAGE_NAME}-image:raspberrypi-armv7:append = " ${RASPBERRYPI_v7_KERNEL_PACKAGE_NAME}-image" |
| 24 | RDEPENDS:${KERNEL_PACKAGE_NAME}-dev:raspberrypi-armv7:append = " ${RASPBERRYPI_v7_KERNEL_PACKAGE_NAME}-dev" |
| 25 | RDEPENDS:${KERNEL_PACKAGE_NAME}-vmlinux:raspberrypi-armv7:append = " ${RASPBERRYPI_v7_KERNEL_PACKAGE_NAME}-vmlinux" |
| 26 | RDEPENDS:${KERNEL_PACKAGE_NAME}-modules:raspberrypi-armv7:append = " ${RASPBERRYPI_v7_KERNEL_PACKAGE_NAME}-modules" |
| 27 | RDEPENDS:${KERNEL_PACKAGE_NAME}-dbg:raspberrypi-armv7:append = " ${RASPBERRYPI_v7_KERNEL_PACKAGE_NAME}-dbg" |
| 28 | |
| 29 | DEPLOYDEP = "" |
| 30 | DEPLOYDEP:raspberrypi-armv7 = "${RASPBERRYPI_v7_KERNEL}:do_deploy" |
| 31 | do_deploy[depends] += "${DEPLOYDEP}" |