Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Lua is a powerful light-weight programming language designed \ |
| 2 | for extending applications." |
| 3 | LICENSE = "MIT" |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://doc/readme.html;beginline=318;endline=352;md5=f43d8ee6bc4df18ef8b276439cc4a153" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 5 | HOMEPAGE = "http://www.lua.org/" |
| 6 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 7 | SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz;name=tarballsrc \ |
| 8 | file://lua.pc.in \ |
Brad Bishop | 00ab237 | 2019-10-14 11:06:18 -0400 | [diff] [blame] | 9 | file://0001-Allow-building-lua-without-readline-on-Linux.patch \ |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 10 | file://CVE-2020-15888.patch \ |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 11 | file://0001-Fixed-bug-barriers-cannot-be-active-during-sweep.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 12 | " |
| 13 | |
| 14 | # if no test suite matches PV release of Lua exactly, download the suite for the closest Lua release. |
| 15 | PV_testsuites = "5.3.4" |
| 16 | |
| 17 | SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', \ |
| 18 | 'http://www.lua.org/tests/lua-${PV_testsuites}-tests.tar.gz;name=tarballtest \ |
| 19 | file://run-ptest \ |
| 20 | ', '', d)}" |
| 21 | |
Andrew Geissler | eef6386 | 2021-01-29 15:58:13 -0600 | [diff] [blame] | 22 | SRC_URI[tarballsrc.md5sum] = "83f23dbd5230140a3770d5f54076948d" |
| 23 | SRC_URI[tarballsrc.sha256sum] = "fc5fd69bb8736323f026672b1b7235da613d7177e72558893a0bdcd320466d60" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 24 | SRC_URI[tarballtest.md5sum] = "b14fe3748c1cb2d74e3acd1943629ba3" |
| 25 | SRC_URI[tarballtest.sha256sum] = "b80771238271c72565e5a1183292ef31bd7166414cd0d43a8eb79845fa7f599f" |
| 26 | |
| 27 | inherit pkgconfig binconfig ptest |
| 28 | |
Brad Bishop | 00ab237 | 2019-10-14 11:06:18 -0400 | [diff] [blame] | 29 | PACKAGECONFIG ??= "readline" |
| 30 | PACKAGECONFIG[readline] = ",,readline" |
| 31 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 32 | TARGET_CC_ARCH += " -fPIC ${LDFLAGS}" |
Brad Bishop | 00ab237 | 2019-10-14 11:06:18 -0400 | [diff] [blame] | 33 | EXTRA_OEMAKE = "'CC=${CC} -fPIC' 'MYCFLAGS=${CFLAGS} -fPIC' MYLDFLAGS='${LDFLAGS}'" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 34 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 35 | do_configure:prepend() { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 36 | sed -i -e s:/usr/local:${prefix}:g src/luaconf.h |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 37 | sed -i -e s:lib/lua/:${baselib}/lua/:g src/luaconf.h |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 38 | } |
| 39 | |
| 40 | do_compile () { |
Brad Bishop | 00ab237 | 2019-10-14 11:06:18 -0400 | [diff] [blame] | 41 | oe_runmake ${@bb.utils.contains('PACKAGECONFIG', 'readline', 'linux', 'linux-no-readline', d)} |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 42 | } |
| 43 | |
| 44 | do_install () { |
| 45 | oe_runmake \ |
| 46 | 'INSTALL_TOP=${D}${prefix}' \ |
| 47 | 'INSTALL_BIN=${D}${bindir}' \ |
| 48 | 'INSTALL_INC=${D}${includedir}/' \ |
| 49 | 'INSTALL_MAN=${D}${mandir}/man1' \ |
| 50 | 'INSTALL_SHARE=${D}${datadir}/lua' \ |
| 51 | 'INSTALL_LIB=${D}${libdir}' \ |
| 52 | 'INSTALL_CMOD=${D}${libdir}/lua/5.3' \ |
| 53 | install |
| 54 | install -d ${D}${libdir}/pkgconfig |
| 55 | |
| 56 | sed -e s/@VERSION@/${PV}/ ${WORKDIR}/lua.pc.in > ${WORKDIR}/lua.pc |
| 57 | install -m 0644 ${WORKDIR}/lua.pc ${D}${libdir}/pkgconfig/ |
| 58 | rmdir ${D}${datadir}/lua/5.3 |
| 59 | rmdir ${D}${datadir}/lua |
| 60 | } |
| 61 | |
| 62 | do_install_ptest () { |
| 63 | cp -R --no-dereference --preserve=mode,links -v ${WORKDIR}/lua-${PV_testsuites}-tests ${D}${PTEST_PATH}/test |
| 64 | } |
| 65 | |
| 66 | BBCLASSEXTEND = "native nativesdk" |