Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright Matthias Hentges <devel@hentges.net> (c) 2006 |
| 3 | # License: MIT (see http://www.opensource.org/licenses/mit-license.php for a copy of the license) |
| 4 | # |
| 5 | # Filename: fbset_2.1.bb |
| 6 | # Date: 28-May-06 |
| 7 | |
| 8 | SUMMARY = "The fbset console tool" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 9 | HOMEPAGE = "http://users.telenet.be/geertu/Linux/fbdev/" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 10 | LICENSE = "GPLv2" |
| 11 | LIC_FILES_CHKSUM = "file://fbset.c;endline=19;md5=bf326f82cdfcac391af208f019c5603f" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 12 | RRECOMMENDS:${PN} = "fbset-modes" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 13 | DEPENDS = "bison-native flex-native" |
| 14 | |
| 15 | PR = "r4" |
| 16 | |
Andrew Geissler | 8fc454f | 2020-12-11 16:27:59 -0600 | [diff] [blame] | 17 | SRC_URI = "${DEBIAN_MIRROR}/main/f/fbset/fbset_2.1.orig.tar.gz \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 18 | file://makefile.patch \ |
| 19 | file://fbset-2.1-fix-makefile-dep.patch \ |
| 20 | file://0001-fbset-including-asm-types.h-is-needed-on-all-linux-s.patch \ |
| 21 | " |
| 22 | |
| 23 | inherit update-alternatives |
| 24 | |
| 25 | do_install() { |
| 26 | install -d ${D}${sbindir} ${D}${datadir}/man/man8 ${D}${datadir}/man/man5 |
| 27 | install -m 0755 ${B}/fbset ${D}${sbindir}/fbset.real |
| 28 | install -m 0644 ${B}/*.5 ${D}${datadir}/man/man5 |
| 29 | install -m 0644 ${B}/*.8 ${D}${datadir}/man/man8 |
| 30 | } |
| 31 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | ALTERNATIVE:fbset = "fbset" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 33 | ALTERNATIVE_LINK_NAME[fbset] = "${sbindir}/fbset" |
| 34 | ALTERNATIVE_TARGET[fbset] = "${sbindir}/fbset.real" |
| 35 | ALTERNATIVE_PRIORITY[fbset] = "55" |
| 36 | |
| 37 | SRC_URI[md5sum] = "40ed9608f46d787bfb65fd1269f7f459" |
| 38 | SRC_URI[sha256sum] = "517fa062d7b2d367f931a1c6ebb2bef84907077f0ce3f0c899e34490bbea9338" |