Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "JSON Web Token implementation in Python" |
| 2 | DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\ |
| 3 | Original implementation was written by https://github.com/progrium" |
| 4 | HOMEPAGE = "http://github.com/jpadilla/pyjwt" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=68626705a7b513ca8d5f44a3e200ed0c" |
| 7 | |
| 8 | SRC_URI[md5sum] = "a4712f980c008696e13e09504120b2a0" |
| 9 | SRC_URI[sha256sum] = "8d59a976fb773f3e6a39c85636357c4f0e242707394cadadd9814f5cbaa20e96" |
| 10 | |
| 11 | PYPI_PACKAGE = "PyJWT" |
| 12 | inherit pypi setuptools3 |
| 13 | |
| 14 | RDEPENDS_${PN} = "${PYTHON_PN}-cryptography" |
| 15 | |
| 16 | BBCLASSEXTEND = "native nativesdk" |