blob: 7c748bc49bec47df03ed5213f6cd213aa0fb7be0 [file] [log] [blame]
Patrick Williams73bd93f2024-02-20 08:07:48 -06001SUMMARY = "Support for assertion checking and logging in GNU C/C++"
2DESCRIPTION = "GNU Nana is a free library providing improved support for assertion\
3checking (as in assert.h) and logging (printf style debugging) in \
4GNU C and C++."
5SECTION = "Development/Languages/C and C++"
6
7PV = "2.5+git"
8SRCREV = "6d70617db8b9972e6c1008265fc228aba91c2042"
9SRC_URI = "git://github.com/pjmaker/nana;protocol=https;branch=master \
10 file://0001-Makefile.am-fix-build-with-separate-build-dir.patch \
11 file://0002-man-Makefile.am-we-seem-not-to-need-the-work-around-.patch \
12"
13S = "${WORKDIR}/git"
14
15LICENSE = "BSD-2-Clause"
16
17LIC_FILES_CHKSUM = "file://COPYING;md5=16aa57f3b7fdda870cee597275bd5d11"
18
19inherit autotools pkgconfig texinfo
20
21EXTRA_OEMAKE = "DESTDIR=${D}"
22
23do_configure:prepend() {
24 # make distclean but in ${S}
25 rm -rf ${S}/src/*.o ${S}/src/.deps \
26 ${S}/Makefile ${S}/config.log ${S}/config.status \
27 ${S}/doc/Makefile ${S}/doc/nana.pdf \
28 ${S}/emacs/Makefile ${S}/examples/Makefile \
29 ${S}/gdb/Makefile ${S}/gdb/nana-libtrace ${S}/gdb/nana-trace \
30 ${S}/man/Makefile ${S}/perf/Makefile \
31 ${S}/shortform/Makefile ${S}/shortform/nana-sfdir ${S}/shortform/nana-sfg \
32 ${S}/src/Makefile ${S}/src/libnana.a \
33 ${S}/src/nana ${S}/src/nana-c++lg ${S}/src/nana-clg ${S}/src/nana-config.h ${S}/src/nana-run ${S}/src/nanafilter \
34 ${S}/test/Makefile ${S}/test/gammon
35}
36
37do_configure:prepend:class-nativesdk() {
38 sed -i -e 's:@CPP@:\$\{CXX\} \$\{CXXFLAGS\} \-E:g' ${S}/src/nana.in
39 sed -i -e 's:@CC@:\$\{CC\} \$\{CFLAGS\} \-E:g' ${S}/src/nana-clg.in
40 sed -i -e 's:@CXX@::g' ${S}/src/nana-c++lg.in
41 sed -i -e 's:@GDB@:\$\{GDB\}:g' ${S}/src/nana-run.in
42}
43
44BBCLASSEXTEND = "native nativesdk"