Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | DESCRIPTION = "A modern, C++-native, header-only, test framework for unit-tests, \ |
| 2 | TDD and BDD - using C++11, C++14, C++17 and later." |
| 3 | HOMEPAGE = "https://github.com/catchorg/Catch2" |
| 4 | LICENSE = "BSL-1.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c" |
| 6 | |
| 7 | SRC_URI = "git://github.com/catchorg/Catch2.git;branch=v2.x;protocol=https" |
| 8 | SRCREV = "182c910b4b63ff587a3440e08f84f70497e49a81" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | inherit cmake python3native |
| 13 | |
| 14 | do_install:append() { |
| 15 | rm ${D}${datadir}/Catch2/lldbinit |
| 16 | rm ${D}${datadir}/Catch2/gdbinit |
| 17 | rmdir ${D}${datadir}/Catch2/ |
| 18 | } |
| 19 | # Header-only library |
| 20 | RDEPENDS:${PN}-dev = "" |
| 21 | RRECOMMENDS:${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})" |