Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 1 | SUMMARY = "A DSP library for telephony" |
| 2 | DESCRIPTION = "\ |
| 3 | SpanDSP is a low-level signal processing library that modulates and \ |
| 4 | demodulates signals commonly used in telephony, such as the \"noise\" \ |
| 5 | generated by a fax modem or DTMF touchpad. \ |
| 6 | " |
| 7 | HOMEPAGE = "https://www.soft-switch.org/" |
| 8 | BUGTRACKER = "https://github.com/freeswitch/spandsp/issues" |
| 9 | SECTION = "libs" |
| 10 | LICENSE = "LGPL-2.1-only" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=8791c23ddf418deb5be264cffb5fa6bc" |
| 12 | |
| 13 | DEPENDS = "\ |
| 14 | libxml2 \ |
| 15 | tiff \ |
| 16 | tiff-native \ |
| 17 | " |
| 18 | |
| 19 | PV = "3.0.0+git" |
| 20 | |
| 21 | SRC_URI = "\ |
| 22 | git://github.com/freeswitch/spandsp.git;protocol=https;branch=master \ |
| 23 | file://configure.patch \ |
| 24 | file://makefile.patch \ |
| 25 | " |
| 26 | # Fails to build with Clang since 5394b2cae6c482ccb835335b769469977e6802ae |
| 27 | # https://github.com/freeswitch/spandsp/issues/67 |
| 28 | # https://lists.openembedded.org/g/openembedded-devel/message/109325 |
| 29 | SRCREV = "df1282eb9af538ab1aadb6d66146e258451d4fe4" |
| 30 | |
| 31 | S = "${WORKDIR}/git" |
| 32 | |
| 33 | inherit autotools |
| 34 | |
| 35 | PACKAGECONFIG ?= "" |
| 36 | |
| 37 | PACKAGECONFIG[mmx] = "--enable-mmx,--disable-mmx" |
| 38 | PACKAGECONFIG[sse] = "--enable-sse,--disable-sse" |
| 39 | PACKAGECONFIG[sse2] = "--enable-sse2,--disable-sse2" |
| 40 | PACKAGECONFIG[sse3] = "--enable-sse3,--disable-sse3" |
| 41 | PACKAGECONFIG[ssse3] = "--enable-ssse3,--disable-ssse3" |
| 42 | PACKAGECONFIG[sse4-1] = "--enable-sse4-1,--disable-sse4-1" |
| 43 | PACKAGECONFIG[sse4-2] = "--enable-sse4-2,--disable-sse4-2" |
| 44 | PACKAGECONFIG[avx] = "--enable-avx,--disable-avx" |
| 45 | PACKAGECONFIG[avx2] = "--enable-avx2,--disable-avx2" |
| 46 | PACKAGECONFIG[neon] = "--enable-neon,--disable-neon" |
| 47 | PACKAGECONFIG[fixed-point] = "--enable-fixed-point,--disable-fixed-point" |
| 48 | PACKAGECONFIG[v32bis] = "--enable-v32bis,--disable-v32bis" |
| 49 | PACKAGECONFIG[v34] = "--enable-v34,--disable-v34" |
| 50 | PACKAGECONFIG[sslfax] = "--enable-sslfax,--disable-sslfax" |