blob: 20b7e3d0a578cbc225eed4beb1071b14f6963f7a [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.sourceforge.net"
3SECTION = "console/utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
8 file://0001-Add-linux-aarch64-arch_regs.h.patch \
9 file://git-version-gen \
10 file://strace-add-configure-options.patch \
11 file://Makefile-ptest.patch \
12 file://run-ptest \
13 file://Include-sys-stat.h-for-S_I-macros.patch \
14 file://Include-linux-ioctl.h-for-_IOC_-macros.patch \
15 "
16
17SRC_URI[md5sum] = "107a5be455493861189e9b57a3a51912"
18SRC_URI[sha256sum] = "e6180d866ef9e76586b96e2ece2bfeeb3aa23f5cc88153f76e9caedd65e40ee2"
19
20inherit autotools ptest bluetooth
21RDEPENDS_${PN}-ptest += "make coreutils grep gawk"
22
23PACKAGECONFIG_class-target ??= "\
24 libaio ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
26"
27
28PACKAGECONFIG[libaio] = "--enable-aio,--disable-aio,libaio"
29PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
30PACKAGECONFIG[libunwind] = "--with-libunwind, --without-libunwind, libunwind"
31PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"
32
33TESTDIR = "tests"
34
35do_configure_prepend() {
36 cp ${WORKDIR}/git-version-gen ${S}
37}
38
39do_install_append() {
40 # We don't ship strace-graph here because it needs perl
41 rm ${D}${bindir}/strace-graph
42}
43
44do_compile_ptest() {
45 oe_runmake -C ${TESTDIR} buildtest-TESTS OS=linux ARCH="${TARGET_ARCH}"
46}
47
48do_install_ptest() {
49 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
50}
51
52BBCLASSEXTEND = "native"