Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | require ttf.inc |
| 2 | |
| 3 | SUMMARY = "Japanese TrueType fonts from Vine Linux" |
| 4 | AUTHOR = "Contributor: noonov <noonov@gmail.com>" |
| 5 | HOMEPAGE = "http://vlgothic.dicey.org/" |
| 6 | |
| 7 | LICENSE = "mplus & BSD" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE.en;md5=66ecd0fd7e4da6246fa30317c7b66755 \ |
| 9 | file://LICENSE_E.mplus;md5=1c4767416f20215f1e61b970f2117db9 \ |
| 10 | " |
| 11 | |
| 12 | SRC_URI = "https://osdn.jp/dl/vlgothic/VLGothic-${PV}.tar.xz" |
| 13 | |
| 14 | SRC_URI[md5sum] = "bb7fadb2dff09a4fb6a11dc9dfdc0c36" |
| 15 | SRC_URI[sha256sum] = "982040db2f9cb73d7c6ab7d9d163f2ed46d1180f330c9ba2fae303649bf8102d" |
| 16 | |
| 17 | S = "${WORKDIR}/VLGothic" |
| 18 | |
| 19 | do_install_append () { |
| 20 | install -D -m644 ${S}/LICENSE_E.mplus ${D}${datadir}/licenses/${PN}/COPYING_MPLUS.txt |
| 21 | install -D -m644 ${S}/README.sazanami ${D}${datadir}/licenses/${PN}/COPYING_SAZANAMI.txt |
| 22 | install -D -m644 ${S}/LICENSE.en ${D}${datadir}/licenses/${PN}/COPYING_VLGOTHIC.txt |
| 23 | } |
| 24 | |
| 25 | PACKAGES = "${PN}" |
| 26 | FONT_PACKAGES = "${PN}" |
| 27 | |
| 28 | FILES_${PN} = "${datadir}/fonts/truetype ${datadir}/licenses" |