Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Open Package Manager" |
| 2 | SUMMARY_libopkg = "Open Package Manager library" |
| 3 | SECTION = "base" |
| 4 | HOMEPAGE = "http://code.google.com/p/opkg/" |
| 5 | BUGTRACKER = "http://code.google.com/p/opkg/issues/list" |
| 6 | LICENSE = "GPLv2+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 8 | file://src/opkg.c;beginline=2;endline=21;md5=90435a519c6ea69ef22e4a88bcc52fa0" |
| 9 | |
| 10 | DEPENDS = "libarchive" |
| 11 | |
| 12 | PE = "1" |
| 13 | |
| 14 | SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \ |
| 15 | file://opkg.conf \ |
| 16 | file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \ |
| 17 | file://0001-libopkg-add-add-ignore-recommends-option.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 18 | file://0001-regress-issue72.py-resolve-paths-before-comparision.patch \ |
| 19 | file://0001-opkg-add-target-for-testsuite-installation.patch \ |
| 20 | file://run-ptest \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | " |
| 22 | |
| 23 | SRC_URI[md5sum] = "ae51d95fee599bb4dce08453529158f5" |
| 24 | SRC_URI[sha256sum] = "f6c00515d8a2ad8f6742a8e73830315d1983ed0459cba77c4d656cfc9e7fe6fe" |
| 25 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 26 | # This needs to be before ptest inherit, otherwise all ptest files end packaged |
| 27 | # in libopkg package if OPKGLIBDIR == libdir, because default |
| 28 | # PTEST_PATH ?= "${libdir}/${BPN}/ptest" |
| 29 | PACKAGES =+ "libopkg" |
| 30 | |
| 31 | inherit autotools pkgconfig systemd ptest |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 32 | |
| 33 | target_localstatedir := "${localstatedir}" |
| 34 | OPKGLIBDIR = "${target_localstatedir}/lib" |
| 35 | |
| 36 | PACKAGECONFIG ??= "libsolv" |
| 37 | |
| 38 | PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg" |
| 39 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl" |
| 40 | PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl" |
| 41 | PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" |
| 42 | PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256" |
| 43 | PACKAGECONFIG[pathfinder] = "--enable-pathfinder,--disable-pathfinder,pathfinder" |
| 44 | PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv" |
| 45 | |
| 46 | EXTRA_OECONF_class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}" |
| 47 | |
| 48 | do_install_append () { |
| 49 | install -d ${D}${sysconfdir}/opkg |
| 50 | install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf |
| 51 | echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf |
| 52 | |
| 53 | # We need to create the lock directory |
| 54 | install -d ${D}${OPKGLIBDIR}/opkg |
| 55 | } |
| 56 | |
| 57 | RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive" |
| 58 | RDEPENDS_${PN}_class-native = "" |
| 59 | RDEPENDS_${PN}_class-nativesdk = "" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 60 | RDEPENDS_${PN}-ptest += "make binutils python3-core python3-compression" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 61 | RREPLACES_${PN} = "opkg-nogpg opkg-collateral" |
| 62 | RCONFLICTS_${PN} = "opkg-collateral" |
| 63 | RPROVIDES_${PN} = "opkg-collateral" |
| 64 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 65 | FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/" |
| 66 | |
| 67 | BBCLASSEXTEND = "native nativesdk" |
| 68 | |
| 69 | CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf" |