Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 1 | LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=9aa91e13d644326bf281924212862184" |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 2 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
Ed Tanous | d9aea6f | 2019-01-11 16:26:13 -0800 | [diff] [blame] | 3 | DEPENDS += "systemd" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 4 | SRCREV = "c3939dac2c060651361fc71516806f9ab8c38901" |
| 5 | PV = "1.8.18+git${SRCPV}" |
Ed Tanous | d9aea6f | 2019-01-11 16:26:13 -0800 | [diff] [blame] | 6 | |
Patrick Williams | bb99d22 | 2022-01-24 15:55:09 -0600 | [diff] [blame] | 7 | SRC_URI = "git://github.com/ipmitool/ipmitool.git;protocol=https;branch=master" |
Vernon Mauery | e0b32cb | 2020-03-04 11:02:02 -0800 | [diff] [blame] | 8 | # TODO: when a new company joins the OpenBMC project by signing |
| 9 | # a CLA, if they have an enterprise number on file with the |
| 10 | # IANA, the versioned file, $PWD/ipmitool/enterprise-numbers |
| 11 | # needs to be updated to add their entry. The canonical |
| 12 | # version of the file is locatede here: |
| 13 | # https://www.iana.org/assignments/enterprise-numbers |
| 14 | # |
| 15 | # This file is manually downloaded so it can be versioned |
| 16 | # instead of having the makefile download it during do_compile |
Vernon Mauery | 5896a23 | 2019-04-23 15:31:51 -0700 | [diff] [blame] | 17 | SRC_URI += " \ |
Vernon Mauery | e0b32cb | 2020-03-04 11:02:02 -0800 | [diff] [blame] | 18 | file://enterprise-numbers \ |
Vernon Mauery | 5896a23 | 2019-04-23 15:31:51 -0700 | [diff] [blame] | 19 | " |
| 20 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | EXTRA_OECONF:append = " --disable-ipmishell --enable-intf-dbus DEFAULT_INTF=dbus " |
| 24 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 25 | do_compile:prepend() { |
Vernon Mauery | e0b32cb | 2020-03-04 11:02:02 -0800 | [diff] [blame] | 26 | # copy the SRC_URI version of enterprise-numbers |
| 27 | # to the build dir to prevent a fetch |
James Feist | 1984127 | 2020-05-01 14:35:25 -0700 | [diff] [blame] | 28 | mkdir -p "${WORKDIR}/build" |
Vernon Mauery | e0b32cb | 2020-03-04 11:02:02 -0800 | [diff] [blame] | 29 | cp "${WORKDIR}/enterprise-numbers" "${WORKDIR}/build/enterprise-numbers" |
| 30 | } |
| 31 | |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 32 | # make sure that the enterprise-numbers file gets installed in the root FS |
Patrick Williams | c7d8802 | 2023-03-24 09:39:28 -0500 | [diff] [blame^] | 33 | FILES:${PN} += "${datadir}/misc/enterprise-numbers" |