Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Evince is a document viewer for document formats like pdf, ps, djvu" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=96f2f8d5ee576a2163977938ea36fa7b" |
| 4 | SECTION = "x11/office" |
| 5 | DEPENDS = "gtk+3 libsecret ${@bb.utils.contains('DISTRO_FEATURES','x11','gnome-desktop3','',d)} poppler gstreamer1.0-plugins-base orc adwaita-icon-theme intltool-native gnome-common-native" |
| 6 | |
| 7 | inherit gnome pkgconfig gtk-icon-cache gsettings gobject-introspection distro_features_check systemd |
| 8 | |
| 9 | REQUIRED_DISTRO_FEATURES = "x11" |
| 10 | |
| 11 | SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@gnome_verdir("${PV}")}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \ |
| 12 | file://0001-help-remove-YELP-macro.patch \ |
| 13 | file://0001-Add-format-attribute-to-_synctex_malloc.patch \ |
| 14 | file://0001-add-a-formatting-attribute-check.patch \ |
| 15 | " |
| 16 | SRC_URI[archive.md5sum] = "66aa1766eaaa37536e48def11a0e67a3" |
| 17 | SRC_URI[archive.sha256sum] = "0955d22d85c9f6d322b6cbb464f1cc4c352db619017ec95dad4cc5c3440f73e1" |
| 18 | |
| 19 | EXTRA_OECONF = "--enable-thumbnailer" |
| 20 | |
| 21 | do_compile_prepend() { |
| 22 | export GIR_EXTRA_LIBS_PATH="${B}/libdocument/.libs" |
| 23 | } |
| 24 | |
| 25 | |
| 26 | do_install_append() { |
| 27 | install -d ${D}${datadir}/pixmaps |
| 28 | install -m 0755 ${S}/data/icons/48x48/apps/evince.png ${D}${datadir}/pixmaps/ |
| 29 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)} |
| 30 | then |
| 31 | install -d ${D}${systemd_unitdir}/system |
| 32 | mv ${D}${systemd_user_unitdir}/evince.service ${D}${systemd_system_unitdir}/evince.service |
| 33 | else |
| 34 | rm -rf ${D}${libdir}/systemd/user/evince.service |
| 35 | fi |
| 36 | rmdir --ignore-fail-on-non-empty ${D}${systemd_user_unitdir} |
| 37 | rmdir --ignore-fail-on-non-empty ${D}${nonarch_libdir}/systemd |
| 38 | rmdir --ignore-fail-on-non-empty ${D}${nonarch_libdir} |
| 39 | } |
| 40 | |
| 41 | PACKAGECONFIG ??= "" |
| 42 | PACKAGECONFIG[nautilus] = "--enable-nautilus,--disable-nautilus,nautilus" |
| 43 | PACKAGECONFIG[browser-plugin] = "--enable-browser-plugin,--disable-browser-plugin," |
| 44 | |
| 45 | SYSTEMD_SERVICE_${PN} = "evince.service" |
| 46 | |
| 47 | RDEPENDS_${PN} += "glib-2.0-utils" |
| 48 | RRECOMMMENDS_${PN} = "adwaita-icon-theme" |
| 49 | |
| 50 | PACKAGES =+ "${PN}-nautilus-extension" |
| 51 | PACKAGES =+ "${PN}-browser-plugin" |
| 52 | |
| 53 | FILES_${PN} += "${datadir}/dbus-1 \ |
| 54 | ${datadir}/metainfo \ |
| 55 | ${datadir}/thumbnailers \ |
| 56 | ${systemd_unitdir}/systemd/user/evince.service \ |
| 57 | " |
| 58 | FILES_${PN}-dbg += "${libdir}/*/*/.debug \ |
| 59 | ${libdir}/*/*/*/.debug" |
| 60 | FILES_${PN}-dev += "${libdir}/nautilus/extensions-2.0/*.la \ |
| 61 | ${libdir}/evince/*/backends/*.la" |
| 62 | FILES_${PN}-staticdev += "${libdir}/nautilus/extensions-2.0/*.a \ |
| 63 | ${libdir}/evince/*/backends/*.a" |
| 64 | FILES_${PN}-nautilus-extension = "${libdir}/nautilus/*/*so" |
| 65 | FILES_${PN}-browser-plugin = "${libdir}/mozilla/*/*so" |