Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "GNOME editor" |
| 2 | SECTION = "x11/gnome" |
| 3 | LICENSE = "GPLv2+" |
| 4 | PR = "r2" |
| 5 | |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 6 | DEPENDS = "gvfs enchant gconf gnome-doc-utils glib-2.0 gtk+ \ |
| 7 | gtksourceview2 iso-codes intltool-native gnome-common-native \ |
| 8 | libice python3-six-native" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 9 | |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 11 | |
Brad Bishop | 757e94a | 2018-09-07 18:58:51 +0000 | [diff] [blame] | 12 | inherit distro_features_check gnome gettext python3native |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 13 | |
| 14 | REQUIRED_DISTRO_FEATURES = "x11" |
| 15 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 16 | SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@gnome_verdir("${PV}")}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \ |
| 17 | file://0001-workaround-void-pointer-arithmetic.patch \ |
| 18 | file://0001-Remove-help-directory-from-build.patch \ |
| 19 | file://0002-suppress-string-format-literal-warning-to-fix-build-.patch \ |
| 20 | file://0001-tests-document-saver.c-Define-ACCESSPERMS-if-not-def.patch \ |
| 21 | file://0001-gedit-utils-qualify-handle_builder_error-with-format.patch \ |
| 22 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 23 | SRC_URI[archive.md5sum] = "e1eecb0a92a1a363b3d375ec5ac0fb3b" |
| 24 | SRC_URI[archive.sha256sum] = "a561fe3dd1d199baede1bd07c4ee65f06fc7c494dd4d3327117f04149a608e3c" |
| 25 | GNOME_COMPRESS_TYPE="bz2" |
| 26 | |
| 27 | EXTRA_OECONF = "--disable-scrollkeeper \ |
| 28 | --enable-gvfs-metadata" |
| 29 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 30 | LDFLAGS += "-lgmodule-2.0 -lICE" |
| 31 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 32 | FILES_${PN} += "${libdir}/gedit-2/plugin* ${datadir}/gedit-2" |
| 33 | FILES_${PN}-dbg += "${libdir}/gedit-2/plugin-loaders/.debug ${libdir}/gedit-2/plugins/.debug" |