Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Inspect and manipulate eBPF programs and maps" |
| 2 | DESCRIPTION = "bpftool is a kernel tool for inspection and simple manipulation \ |
| 3 | of eBPF programs and maps." |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" |
| 6 | DEPENDS = "binutils elfutils" |
| 7 | PROVIDES = "virtual/bpftool" |
| 8 | |
| 9 | inherit bash-completion kernelsrc kernel-arch |
| 10 | |
| 11 | do_populate_lic[depends] += "virtual/kernel:do_patch" |
| 12 | |
| 13 | EXTRA_OEMAKE = "-C ${S}/tools/bpf/bpftool O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}" |
| 14 | |
| 15 | do_configure[depends] += "virtual/kernel:do_shared_workdir" |
| 16 | |
Andrew Geissler | 1548c07 | 2019-02-22 16:03:50 -0600 | [diff] [blame] | 17 | COMPATIBLE_HOST_libc-musl = 'null' |
| 18 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | do_compile() { |
| 20 | oe_runmake |
| 21 | } |
| 22 | |
| 23 | do_install() { |
| 24 | oe_runmake DESTDIR=${D} install |
| 25 | } |
| 26 | |
| 27 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 28 | |
| 29 | python do_package_prepend() { |
| 30 | d.setVar('PKGV', d.getVar("KERNEL_VERSION", True).split("-")[0]) |
| 31 | } |
| 32 | |
| 33 | B = "${WORKDIR}/${BPN}-${PV}" |