blob: 9a081babab42468deff11d65e050f43b68d0e041 [file] [log] [blame]
Andrew Geissler89770b02020-06-13 10:40:47 -05001SUMMARY = "Physical quantities module"
2DESCRIPTION = "Physical quantities Python module"
3HOMEPAGE = "https://github.com/hgrecco/pint"
4SECTION = "devel/python"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
8
9PYPI_PACKAGE := "Pint"
10
11inherit pypi ptest setuptools3
12
Andrew Geisslerc87764f2020-06-27 00:16:32 -050013SRC_URI[md5sum] = "6e60d42736f8175a57119aecc383fe4b"
14SRC_URI[sha256sum] = "13fa35ffa3ddf53161b4304917085687950e0de461bcdd4d65cdee11a43d7fb2"
Andrew Geissler89770b02020-06-13 10:40:47 -050015
16DEPENDS += "python3-setuptools-scm-native"
17
18BBCLASSEXTEND = "native nativesdk"
19
20SRC_URI += " \
21 file://run-ptest \
22"
23
24RDEPENDS_${PN}-ptest += " \
25 ${PYTHON_PN}-pytest \
26"
27
28do_install_ptest() {
29 install -d ${D}${PTEST_PATH}/testsuite
30 cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
31}