Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | # This recipe is adapted from one in meta-jupyter: |
| 2 | # https://github.com/Xilinx/meta-jupyter/blob/master/recipes-python/python3-sympy_1.1.bb |
| 3 | |
| 4 | SUMMARY = "Computer algebra system (CAS) in Python" |
| 5 | HOMEPAGE = "https://pypi.org/project/sympy/" |
| 6 | LICENSE = "BSD" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=611b41534dbf5aa01d7c827bf667ef66" |
| 8 | |
| 9 | SRC_URI[md5sum] = "b11b310c3e1642bf66e51038cb3c0021" |
| 10 | SRC_URI[sha256sum] = "d77901d748287d15281f5ffe5b0fef62dd38f357c2b827c44ff07f35695f4e7e" |
| 11 | |
| 12 | inherit pypi setuptools3 |
| 13 | |
| 14 | RDEPENDS_${PN} += "python3-mpmath" |
| 15 | |
| 16 | BBCLASSEXTEND = "native nativesdk" |