Adriana Kobylak | 6161f45 | 2015-10-19 14:15:04 -0400 | [diff] [blame] | 1 | SUMMARY = "Temp placeholder for skeleton function" |
| 2 | DESCRIPTION = "Temp placeholder for skeleton repository" |
| 3 | HOMEPAGE = "http://github.com/openbmc/skeleton" |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit obmc-phosphor-license |
| 7 | inherit obmc-phosphor-systemd |
Brad Bishop | c88c37c | 2015-10-21 20:24:23 -0400 | [diff] [blame^] | 8 | inherit obmc-phosphor-chassis-mgmt |
| 9 | inherit obmc-phosphor-event-mgmt |
| 10 | inherit obmc-phosphor-fan-mgmt |
| 11 | inherit obmc-phosphor-flash-mgmt |
| 12 | inherit obmc-phosphor-policy-mgmt |
| 13 | inherit obmc-phosphor-sensor-mgmt |
| 14 | inherit obmc-phosphor-system-mgmt |
Adriana Kobylak | 6161f45 | 2015-10-19 14:15:04 -0400 | [diff] [blame] | 15 | |
| 16 | DEPENDS += "glib-2.0" |
Brad Bishop | 51c0f7d | 2015-10-19 14:22:57 -0400 | [diff] [blame] | 17 | RDEPENDS_${PN} += "python-subprocess python-tftpy" |
Adriana Kobylak | 6161f45 | 2015-10-19 14:15:04 -0400 | [diff] [blame] | 18 | SRC_URI += "git://github.com/openbmc/skeleton" |
Adriana Kobylak | 6161f45 | 2015-10-19 14:15:04 -0400 | [diff] [blame] | 19 | |
Brad Bishop | 6328d49 | 2015-10-19 21:09:11 -0400 | [diff] [blame] | 20 | SRCREV = "831188fedd74d86e137ec0c8e39c7395548ad480" |
Adriana Kobylak | 6161f45 | 2015-10-19 14:15:04 -0400 | [diff] [blame] | 21 | |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | do_compile() { |
| 25 | oe_runmake all |
| 26 | } |
| 27 | |
| 28 | do_install() { |
| 29 | install -d ${D}/${sbindir} ${D}${libdir} |
Brad Bishop | 51c0f7d | 2015-10-19 14:22:57 -0400 | [diff] [blame] | 30 | for i in ${S}/bin/*.py ${S}/bin/*.exe; do |
Adriana Kobylak | 6161f45 | 2015-10-19 14:15:04 -0400 | [diff] [blame] | 31 | install $i ${D}/${sbindir} |
| 32 | done |
| 33 | install ${S}/bin/libopenbmc_intf.so ${D}/${libdir} |
| 34 | } |