Ed Tanous | 9eeb80f | 2020-08-17 15:16:39 -0700 | [diff] [blame] | 1 | #This is largely to improve our build times by not building or installing |
Andrew Geissler | 56a8292 | 2020-11-03 08:16:37 -0600 | [diff] [blame] | 2 | #modules that OpenBMC does not use by our coding standard. Another thing to |
| 3 | #note is that for most targets, coroutine and context libraries are also added |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 4 | #with a BOOST_LIBS:append:<platform> for most targets. Chrono/Thread should not |
Andrew Geissler | 56a8292 | 2020-11-03 08:16:37 -0600 | [diff] [blame] | 5 | #be relied directly, but are required dependencies of context and coroutine. |
| 6 | #See the relevant portion of the openbmc coding standard with regards to boost |
| 7 | #libraries |
Ed Tanous | 9eeb80f | 2020-08-17 15:16:39 -0700 | [diff] [blame] | 8 | # |
| 9 | #https://github.com/openbmc/docs/blob/master/cpp-style-and-conventions.md#boost |
| 10 | # |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 11 | BOOST_LIBS:openbmc-phosphor = "chrono thread context coroutine" |
Ed Tanous | 9eeb80f | 2020-08-17 15:16:39 -0700 | [diff] [blame] | 12 | |