Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Linux libcamera framework" |
| 2 | SECTION = "libs" |
| 3 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 4 | LICENSE = "GPL-2.0+ & LGPL-2.1+" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 5 | |
| 6 | LIC_FILES_CHKSUM = "\ |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 7 | file://LICENSES/GPL-2.0-or-later.txt;md5=fed54355545ffd980b814dab4a3b312c \ |
| 8 | file://LICENSES/LGPL-2.1-or-later.txt;md5=2a4f4fd2128ea2f65047ee63fbca9f68 \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 9 | " |
| 10 | |
| 11 | SRC_URI = " \ |
| 12 | git://linuxtv.org/libcamera.git;protocol=git \ |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 13 | file://0001-uvcvideo-Use-auto-variable-to-avoid-range-loop-warni.patch \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 14 | " |
| 15 | |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 16 | SRCREV = "f490a87fd339fc7443f5d8467ba56a35c750a5f7" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 17 | |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 18 | PV = "202102+git${SRCPV}" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 22 | DEPENDS = "python3-pyyaml-native python3-jinja2-native python3-ply-native python3-jinja2-native udev gnutls boost chrpath-native" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 23 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'qt', 'qtbase qtbase-native', '', d)}" |
| 24 | |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 25 | PACKAGES =+ "${PN}-gst" |
| 26 | |
| 27 | PACKAGECONFIG ??= "" |
| 28 | PACKAGECONFIG[gst] = "-Dgstreamer=enabled,-Dgstreamer=disabled,gstreamer1.0 gstreamer1.0-plugins-base" |
| 29 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 30 | RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland qt', 'qtwayland', '', d)}" |
| 31 | |
| 32 | inherit meson pkgconfig python3native |
| 33 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 34 | do_install_append() { |
| 35 | chrpath -d ${D}${libdir}/libcamera.so |
| 36 | } |
| 37 | |
| 38 | addtask do_recalculate_ipa_signatures_package after do_package before do_packagedata |
| 39 | do_recalculate_ipa_signatures_package() { |
| 40 | local modules |
| 41 | for module in $(find ${PKGD}/usr/lib/libcamera -name "*.so.sign"); do |
| 42 | module="${module%.sign}" |
| 43 | if [ -f "${module}" ] ; then |
| 44 | modules="${modules} ${module}" |
| 45 | fi |
| 46 | done |
| 47 | |
| 48 | ${S}/src/ipa/ipa-sign-install.sh ${B}/src/ipa-priv-key.pem "${modules}" |
| 49 | } |
| 50 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 51 | FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig" |
| 52 | FILES_${PN} += " ${libdir}/libcamera.so" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 53 | FILES_${PN}-gst = "${libdir}/gstreamer-1.0/libgstlibcamera.so" |