blob: 16928f0dbce1a0813a31458ed762e28346e5e64f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Foreign Function Interface for Python calling C code"
2HOMEPAGE = "http://cffi.readthedocs.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf"
5DEPENDS += "libffi ${PYTHON_PN}-pycparser"
6
Andrew Geissler97771a32021-03-05 15:23:11 -06007SRC_URI[sha256sum] = "fd78e5fee591709f32ef6edb9a015b4aa1a5022598e36227500c8f4e02328d9c"
Andrew Geissler82c905d2020-04-13 13:39:40 -05008
9inherit pypi setuptools3
10
11RDEPENDS_${PN}_class-target = " \
12 ${PYTHON_PN}-ctypes \
13 ${PYTHON_PN}-io \
14 ${PYTHON_PN}-pycparser \
15 ${PYTHON_PN}-shell \
16"
17
18BBCLASSEXTEND = "native nativesdk"