blob: 3cf850d1f475ada47198e4741b01a22e04ce6127 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "Protocol Buffers"
2HOMEPAGE = "https://developers.google.com/protocol-buffers/"
3SECTION = "devel/python"
4
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005LICENSE = "BSD-3-Clause"
Brad Bishop0f291cc2019-09-01 15:16:57 -04006LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=19e8f490f9526b1de84f8d949cfcfd4e"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007
Andrew Geisslerc87764f2020-06-27 00:16:32 -05008inherit pypi setuptools3
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009
Andrew Geissler97771a32021-03-05 15:23:11 -060010SRC_URI[sha256sum] = "1d63eb389347293d8915fb47bee0951c7b5dab522a4a60118b9a18f33e21f8ce"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011
12# http://errors.yoctoproject.org/Errors/Details/184715/
13# Can't find required file: ../src/google/protobuf/descriptor.proto
14CLEANBROKEN = "1"
15
16UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/"
Brad Bishop316dfdd2018-06-25 12:45:53 -040017
Andrew Geisslerc87764f2020-06-27 00:16:32 -050018DEPENDS += "protobuf"
19
Brad Bishop316dfdd2018-06-25 12:45:53 -040020RDEPENDS_${PN} += " \
21 ${PYTHON_PN}-datetime \
22 ${PYTHON_PN}-json \
23 ${PYTHON_PN}-logging \
24 ${PYTHON_PN}-netclient \
25 ${PYTHON_PN}-numbers \
26 ${PYTHON_PN}-pkgutil \
27 ${PYTHON_PN}-six \
28 ${PYTHON_PN}-unittest \
29"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030
31# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
Brad Bishop19323692019-04-05 15:28:33 -040032BBCLASSEXTEND = "native nativesdk"
33
Andrew Geisslerc87764f2020-06-27 00:16:32 -050034DISTUTILS_BUILD_ARGS += "--cpp_implementation"
35DISTUTILS_INSTALL_ARGS += "--cpp_implementation"
36
37do_compile_prepend_class-native () {
38 export KOKORO_BUILD_NUMBER="1"
39}