Andrew Geissler | c3d88e4 | 2020-10-02 09:45:00 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Implements a XML/HTML/XHTML Markup safe string for Python" |
| 2 | HOMEPAGE = "http://github.com/mitsuhiko/markupsafe" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75" |
| 5 | |
| 6 | SRC_URI[md5sum] = "43fd756864fe42063068e092e220c57b" |
| 7 | SRC_URI[sha256sum] = "29872e92839765e546828bb7754a68c418d927cd064fd4708fab9fe9c8bb116b" |
| 8 | |
| 9 | PYPI_PACKAGE = "MarkupSafe" |
| 10 | inherit pypi setuptools3 |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame^] | 11 | inherit ${@bb.utils.filter('DISTRO_FEATURES', 'ptest', d)} |
Andrew Geissler | c3d88e4 | 2020-10-02 09:45:00 -0500 | [diff] [blame] | 12 | |
| 13 | RDEPENDS_${PN} += "${PYTHON_PN}-stringold" |
| 14 | |
| 15 | BBCLASSEXTEND = "native nativesdk" |
| 16 | |
| 17 | SRC_URI += " \ |
| 18 | file://run-ptest \ |
| 19 | " |
| 20 | |
| 21 | RDEPENDS_${PN}-ptest += " \ |
| 22 | ${PYTHON_PN}-pytest \ |
| 23 | " |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | install -d ${D}${PTEST_PATH}/tests |
| 27 | cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 28 | } |