blob: acd857f4a906f39accadbb8cf822602f3f6d8ff2 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
9 file://testcases/network/can/filter-tests/COPYING;md5=5b155ea7d7f86eae8e8832955d8b70bc \
10"
11
12DEPENDS = "attr libaio libcap acl openssl zip-native"
13DEPENDS:append:libc-musl = " fts "
14EXTRA_OEMAKE:append:libc-musl = " LIBC=musl "
15EXTRA_OECONF:append:libc-musl = " LIBS=-lfts "
16
17# since ltp contains x86-64 assembler which uses the frame-pointer register,
18# set -fomit-frame-pointer x86-64 to handle cases where optimisation
19# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
20# earlier in CFLAGS, etc.
21CFLAGS:append:x86-64 = " -fomit-frame-pointer"
22TUNE_CCARGS:remove:x86 = "-mfpmath=sse"
23TUNE_CCARGS:remove:x86-64 = "-mfpmath=sse"
24
25CFLAGS:append:powerpc64 = " -D__SANE_USERSPACE_TYPES__"
26CFLAGS:append:mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
Patrick Williams73bd93f2024-02-20 08:07:48 -060027SRCREV = "68737d20556d37364c95776044b1119c0912a36a"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060028
29SRC_URI = "git://github.com/linux-test-project/ltp.git;branch=master;protocol=https \
30 file://0001-Remove-OOM-tests-from-runtest-mm.patch \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060031 "
32
33S = "${WORKDIR}/git"
34
35inherit autotools-brokensep pkgconfig
36
37# Version 20220527 added KVM test infrastructure which currently fails to build with gold due to
38# SORT_NONE in linker script which isn't supported by gold:
39# https://sourceware.org/bugzilla/show_bug.cgi?id=18097
40# https://github.com/linux-test-project/ltp/commit/3fce2064b54843218d085aae326c8f7ecf3a8c41#diff-39268f0855c634ca48c8993fcd2c95b12a65b79e8d9fa5ccd6b0f5a8785c0dd6R36
41LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd', '', d)}"
42LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld', ' -fuse-ld=bfd', '', d)}"
43
44# After 0002-kvm-use-LD-instead-of-hardcoding-ld.patch
45# https://github.com/linux-test-project/ltp/commit/f94e0ef3b7280f886384703ef9019aaf2f2dfebb
46# it fails with gold also a bit later when trying to use *-payload.bin
47# http://errors.yoctoproject.org/Errors/Details/663094/
48# work around this by forcing .bfd linked in LD when ld-is-gold is in DISTRO_FEATURES
49KVM_LD = "${@bb.utils.contains_any('DISTRO_FEATURES', 'ld-is-gold ld-is-lld', '${HOST_PREFIX}ld.bfd${TOOLCHAIN_OPTIONS} ${HOST_LD_ARCH}', '${LD}', d)}"
50
51TARGET_CC_ARCH += "${LDFLAGS}"
52
53export prefix = "/opt/${PN}"
54export exec_prefix = "/opt/${PN}"
55
56PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
57EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
58EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite "
59# ltp network/rpc test cases ftbfs when libtirpc is found
60EXTRA_OECONF += " --without-tirpc "
61
62do_compile() {
63 oe_runmake HOSTCC="${CC_FOR_BUILD}" HOST_CFLAGS="${CFLAGS_FOR_BUILD}" HOST_LDFLAGS="${LDFLAGS_FOR_BUILD}" KVM_LD="${KVM_LD}"
64}
65
66do_install(){
67 install -d ${D}${prefix}/
68 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install include-install
69
70 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
71 # as it lacks dependency on some perl moudle such as LWP::Simple
72 # And this script previously works as a tool for analyzing failures from LTP
73 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
74 # http://khack.osdl.org to retrieve ltp test results run on
75 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
76 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
77
78 # The controllers memcg_stree test seems to cause us hangs and takes 900s
79 # (maybe we expect more regular output?), anyhow, skip it
80 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
81}
82
83RDEPENDS:${PN} = "\
84 attr \
85 bash \
86 bc \
87 coreutils \
88 cpio \
89 cronie \
90 curl \
91 e2fsprogs \
92 e2fsprogs-mke2fs \
93 expect \
94 file \
95 findutils \
96 gawk \
97 gdb \
98 gzip \
99 iproute2 \
100 ldd \
101 libaio \
102 logrotate \
103 net-tools \
104 perl \
105 python3-core \
106 procps \
107 quota \
108 unzip \
109 util-linux \
110 which \
111 tar \
112"
113
114RRECOMMENDS:${PN} += "kernel-module-loop"
115
116FILES:${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
117
118# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
119INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
120INSANE_SKIP:${PN} += "already-stripped staticdev"
121
122remove_broken_musl_sources() {
123 [ "${TCLIBC}" = "musl" ] || return 0
124
125 cd ${S}
126 echo "WARNING: remove unsupported tests (until they're fixed)"
127
128 # sync with upstream
129 # https://github.com/linux-test-project/ltp/blob/master/ci/alpine.sh#L33
130 rm -rfv \
131 testcases/kernel/syscalls/fmtmsg/fmtmsg01.c \
132 testcases/kernel/syscalls/getcontext/getcontext01.c \
133 testcases/kernel/syscalls/rt_tgsigqueueinfo/rt_tgsigqueueinfo01.c \
134 testcases/kernel/syscalls/timer_create/timer_create01.c \
135 testcases/kernel/syscalls/timer_create/timer_create03.c
136}
137do_patch[postfuncs] += "remove_broken_musl_sources"
138
139# Avoid file dependency scans, as LTP checks for things that may or may not
140# exist on the running system. For instance it has specific checks for
141# csh and ksh which are not typically part of OpenEmbedded systems (but
142# can be added via additional layers.)
143SKIP_FILEDEPS:${PN} = '1'