Patrick Williams | f52e3dd | 2024-01-26 13:04:43 -0600 | [diff] [blame] | 1 | KBRANCH ?= "v6.1/standard/base" |
| 2 | |
| 3 | require recipes-kernel/linux/linux-yocto.inc |
| 4 | |
| 5 | # CVE exclusions |
| 6 | include recipes-kernel/linux/cve-exclusion.inc |
| 7 | include recipes-kernel/linux/cve-exclusion_6.1.inc |
| 8 | |
| 9 | SRCREV_machine ?= "6c78fd37122b29c40bd8bb6f43aaa1ba7d6fb53a" |
| 10 | SRCREV_meta ?= "40dede8a165ea5894f172fede6baa0dd94d23fec" |
| 11 | |
| 12 | # set your preferred provider of linux-yocto to 'linux-yocto-upstream', and you'll |
| 13 | # get the <version>/base branch, which is pure upstream -stable, and the same |
| 14 | # meta SRCREV as the linux-yocto-standard builds. Select your version using the |
| 15 | # normal PREFERRED_VERSION settings. |
| 16 | BBCLASSEXTEND = "devupstream:target" |
| 17 | SRCREV_machine:class-devupstream ?= "fec3b1451d5febbc9e04250f879c10f8952e6bed" |
| 18 | PN:class-devupstream = "linux-yocto-upstream" |
| 19 | KBRANCH:class-devupstream = "v6.1/base" |
| 20 | |
| 21 | SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRANCH};protocol=https \ |
| 22 | git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-6.1;destsuffix=${KMETA};protocol=https" |
| 23 | SRC_URI += "file://0001-perf-cpumap-Make-counter-as-unsigned-ints.patch" |
| 24 | |
| 25 | LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" |
| 26 | LINUX_VERSION ?= "6.1.73" |
| 27 | |
| 28 | PV = "${LINUX_VERSION}+git" |
| 29 | |
| 30 | KMETA = "kernel-meta" |
| 31 | KCONF_BSP_AUDIT_LEVEL = "1" |
| 32 | |
| 33 | # Functionality flags |
| 34 | KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc" |
| 35 | KERNEL_FEATURES:append = " ${KERNEL_EXTRA_FEATURES}" |
| 36 | KERNEL_FEATURES:append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "", d)}" |
| 37 | KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/scsi/scsi-debug.scc", "", d)}" |
| 38 | KERNEL_FEATURES:append = " ${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/gpio/mockup.scc", "", d)}" |