blob: e4d3bd509f78fd56592d64011200b0af9e1387e2 [file] [log] [blame]
Brad Bishopc9ed7202019-06-14 12:33:18 -04001SUMMARY = "Vesnin IPMI to DBus Inventory mapping."
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${YADROBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
5
6inherit native
7inherit phosphor-ipmi-host
8
9FILESEXTRAPATHS_prepend := "${THISDIR}/vesnin-ipmi-inventory-map:"
10
11SRC_URI += "file://config.yaml"
12
13PROVIDES += "virtual/phosphor-ipmi-fru-read-inventory"
14
15S = "${WORKDIR}"
16
17do_install() {
18 # TODO: install this to inventory_datadir
19 # after ipmi-fru-parser untangles the host
20 # firmware config from the machine inventory.
21 DEST=${D}${config_datadir}
22
23 install -d ${DEST}
24 install config.yaml ${DEST}
25}