blob: 6d3bce8a1cce06d417a7421aa079b0d21bce2aee [file] [log] [blame]
Andrew Geissler87f5cff2022-09-30 13:13:31 -05001SUMMARY = "user and group account administration library"
2DESCRIPTION = "The libuser library implements a standardized interface for manipulating and administering user \
3and group accounts"
4HOMEPAGE = "https://pagure.io/libuser"
5BUGTRACKER = "https://pagure.io/libuser/issues"
6
7LICENSE = "LGPL-2.0-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
9 file://lib/user.h;endline=19;md5=76b301f63c39fa992062395efbdc9558 \
10 file://samples/testuser.c;endline=19;md5=3b87fa660fa3f4a6bb31d624afe30ba1"
11
12SECTION = "base"
13
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050014SRC_URI = "https://releases.pagure.org/libuser/libuser-${PV}.tar.gz \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050015 file://0001-docs-Disable-building.patch \
16 file://0002-remove-unused-execinfo.h.patch \
Patrick Williams56b44a92024-01-19 08:49:29 -060017 file://gtkdoc.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050018 "
19
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050020SRC_URI[sha256sum] = "ea6094c72cb9e60a42fb53509dc98d124a340f1c9222783b503208adc16a0a8f"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050021
22DEPENDS = "bison-native popt libpam glib-2.0 python3"
23
24inherit autotools features_check gettext python3native python3-dir pkgconfig gtk-doc
25
26REQUIRED_DISTRO_FEATURES = "pam"
27
28EXTRA_OEMAKE = "PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}"
29
Andrew Geissler87f5cff2022-09-30 13:13:31 -050030do_configure:prepend() {
31 install -d ${S}/admin -d ${S}/m4
32 touch ${S}/ABOUT-NLS ${S}/admin/config.rpath
33 cd ${S}
34 bison lib/getdate.y -o lib/getdate.c
35 cd -
36}
37
38PACKAGES += "${PN}-python "
39
40FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
41