Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Pythonic DBus library" |
| 2 | HOMEPAGE = "https://pypi.python.org/pypi/pydbus/" |
| 3 | LICENSE = "LGPL-2.1-only" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a916467b91076e631dd8edb7424769c7" |
| 5 | |
| 6 | SRCREV = "f2e6355a88351e7d644ccb2b4d67b19305507312" |
| 7 | SRC_URI = " \ |
| 8 | git://github.com/LEW21/pydbus.git;protocol=https;branch=master \ |
| 9 | file://0001-make-direction-attribute-conforming-to-introspect.dt.patch \ |
| 10 | file://0002-Support-asynchronous-calls-58.patch \ |
| 11 | file://0003-Support-transformation-between-D-Bus-errors-and-exce.patch \ |
| 12 | file://run-ptest \ |
| 13 | " |
| 14 | |
| 15 | inherit ptest setuptools3 |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | RDEPENDS:${PN} = "python3-pygobject \ |
| 20 | python3-io \ |
| 21 | python3-logging" |
| 22 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 23 | RDEPENDS:${PN}-ptest += "bash" |
Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 24 | |
| 25 | do_install_ptest() { |
| 26 | install -d ${D}${PTEST_PATH}/tests |
| 27 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 28 | } |