Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "GNOME Settings" |
| 2 | DESCRIPTION = "GNOME Settings is GNOME's main interface for configuration of various aspects of your desktop" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e" |
| 5 | |
| 6 | GNOMEBASEBUILDCLASS = "meson" |
| 7 | |
| 8 | inherit gnomebase gsettings gettext vala upstream-version-is-even bash-completion features_check |
| 9 | |
| 10 | DEPENDS = " \ |
| 11 | gdk-pixbuf-native \ |
| 12 | colord-gtk \ |
| 13 | udisks2 \ |
| 14 | upower \ |
| 15 | polkit \ |
| 16 | pulseaudio \ |
| 17 | accountsservice \ |
| 18 | samba \ |
| 19 | gsettings-desktop-schemas \ |
| 20 | gnome-settings-daemon \ |
| 21 | gnome-desktop3 \ |
| 22 | gnome-online-accounts \ |
| 23 | libnma \ |
| 24 | gnome-bluetooth \ |
| 25 | grilo \ |
| 26 | libgtop \ |
| 27 | gsound \ |
| 28 | libpwquality \ |
| 29 | " |
| 30 | |
| 31 | REQUIRED_DISTRO_FEATURES += "polkit pulseaudio systemd x11" |
| 32 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 33 | SRC_URI[archive.md5sum] = "16c228d7de4e9d2d57550791fbca3390" |
| 34 | SRC_URI[archive.sha256sum] = "ac02346bcf3391aa5c86ed857d76689fdb6e43c2b4b20d3ec6eab0ea9fecf754" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 35 | SRC_URI += "file://0001-Add-meson-option-to-pass-sysroot.patch" |
| 36 | |
| 37 | PACKAGECONFIG ??= "ibus ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}" |
| 38 | PACKAGECONFIG[ibus] = "-Dibus=true, -Dibus=false, ibus" |
| 39 | PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false, wayland" |
| 40 | |
| 41 | # Once we have (lib)cheese we can make cheese a PACKAGECONFIG |
| 42 | EXTRA_OEMESON = " \ |
| 43 | -Doe_sysroot=${STAGING_DIR_HOST} \ |
| 44 | -Dcheese=false \ |
| 45 | " |
| 46 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 47 | FILES:${PN} += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 48 | ${datadir}/dbus-1 \ |
| 49 | ${datadir}/gnome-shell \ |
| 50 | ${datadir}/metainfo \ |
| 51 | " |
| 52 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 53 | FILES:${PN}-dev += "${datadir}/gettext" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 54 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 55 | RDEPENDS:${PN} += "gsettings-desktop-schemas" |