Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Hardware RNG based on CPU timing jitter" |
| 2 | DESCRIPTION = "The Jitter RNG provides a noise source using the CPU execution timing jitter. \ |
| 3 | It does not depend on any system resource other than a high-resolution time \ |
| 4 | stamp. It is a small-scale, yet fast entropy source that is viable in almost \ |
| 5 | all environments and on a lot of CPU architectures." |
| 6 | HOMEPAGE = "http://www.chronox.de/jent.html" |
| 7 | LICENSE = "GPLv2+ | BSD-3-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1c94a9d191202a5552f381a023551396 \ |
| 9 | file://LICENSE.gplv2;md5=eb723b61539feef013de476e68b5c50a \ |
| 10 | file://LICENSE.bsd;md5=66a5cedaf62c4b2637025f049f9b826f \ |
| 11 | " |
| 12 | SRC_URI = "git://github.com/smuellerDD/jitterentropy-library.git" |
| 13 | SRCREV = "418c1e64231255aec2167cbb20aab62a0863415d" |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | # remove at next version upgrade or when output changes |
| 17 | HASHEQUIV_HASH_VERSION .= ".2" |
| 18 | |
| 19 | do_configure[noexec] = "1" |
| 20 | |
| 21 | LDFLAGS += "-Wl,-O0" |
| 22 | |
| 23 | do_install () { |
| 24 | oe_runmake install INCDIR="/include" \ |
| 25 | DESTDIR="${D}" \ |
| 26 | PREFIX="${exec_prefix}" \ |
| 27 | LIBDIR="${baselib}" \ |
| 28 | INSTALL_STRIP="install" |
| 29 | } |
| 30 | |