Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 1 | SUMMARY = "Development package for building Applications that use numa" |
| 2 | HOMEPAGE = "http://oss.sgi.com/projects/libnuma/" |
| 3 | DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \ |
| 4 | to run other programs with a specific NUMA policy and a libnuma to do \ |
| 5 | allocations with NUMA policy in applications." |
| 6 | LICENSE = "GPL-2.0 & LGPL-2.1" |
| 7 | SECTION = "apps" |
| 8 | |
| 9 | inherit autotools-brokensep ptest |
| 10 | |
| 11 | LIC_FILES_CHKSUM = "file://README.md;beginline=19;endline=32;md5=f8ff2391624f28e481299f3f677b21bb" |
| 12 | |
| 13 | SRCREV = "dd6de072c92c892a86e18c0fd0dfa1ba57a9a05d" |
| 14 | PV = "2.0.14" |
| 15 | |
| 16 | SRC_URI = "git://github.com/numactl/numactl \ |
| 17 | file://Fix-the-test-output-format.patch \ |
| 18 | file://Makefile \ |
| 19 | file://run-ptest \ |
| 20 | file://0001-define-run-test-target.patch \ |
| 21 | " |
| 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | LDFLAGS:append:riscv64 = " -latomic" |
| 26 | LDFLAGS:append:riscv32 = " -latomic" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 27 | |
| 28 | do_install() { |
| 29 | oe_runmake DESTDIR=${D} prefix=${D}/usr install |
| 30 | #remove the empty man2 directory |
| 31 | rm -r ${D}${mandir}/man2 |
| 32 | } |
| 33 | |
| 34 | do_compile_ptest() { |
| 35 | oe_runmake test |
| 36 | } |
| 37 | |
| 38 | do_install_ptest() { |
| 39 | #install tests binaries |
| 40 | local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \ |
| 41 | mynode nodemap node-parse pagesize prefered randmap realloc_test \ |
| 42 | tbitmap tshared" |
| 43 | |
| 44 | [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test |
| 45 | for i in $test_binaries; do |
| 46 | install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test |
| 47 | done |
| 48 | |
| 49 | local test_scripts="checktopology checkaffinity printcpu regress regress2 \ |
| 50 | shmtest runltp bind_range" |
| 51 | for i in $test_scripts; do |
| 52 | install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test |
| 53 | done |
| 54 | |
| 55 | install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/ |
| 56 | install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/ |
| 57 | } |
| 58 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 59 | RDEPENDS:${PN}-ptest = "bash" |