Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | DESCRIPTION = "lib-curses provides an interface between Perl programs and \ |
| 2 | the curses library." |
| 3 | |
| 4 | SECTION = "libs" |
| 5 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=0b37356c5e9e28080a3422d82af8af09" |
| 8 | |
| 9 | DEPENDS += "perl ncurses " |
| 10 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 11 | SRC_URI = "http://www.cpan.org/authors/id/G/GI/GIRAFFED/Curses-${PV}.tar.gz \ |
| 12 | file://0001-testtyp.c-Use-proper-prototype-for-main-function.patch \ |
| 13 | " |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 14 | |
| 15 | SRC_URI[sha256sum] = "fb9efea8c7b5ed5f8ea5dee49d35252accfc05ee6e75cb9a37ab7c847cd261d7" |
| 16 | |
| 17 | S = "${WORKDIR}/Curses-${PV}" |
| 18 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 19 | EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS=-L${STAGING_LIBDIR} TEST_SYMS_OPTS=-v" |
| 20 | |
| 21 | # enable NCURSES_WIDECHAR=1 only if ENABLE_WIDEC has not been explicitly disabled (e.g. by the distro config). |
| 22 | # When compiling against the ncurses library, NCURSES_WIDECHAR needs to explicitly set to 0 in this case. |
| 23 | CFLAGS:append:libc-musl = "${@' -DNCURSES_WIDECHAR=1' if bb.utils.to_boolean((d.getVar('ENABLE_WIDEC') or 'True')) else ' -DNCURSES_WIDECHAR=0'} -DNCURSES_INTERNALS" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 24 | |
| 25 | inherit cpan |
| 26 | |
| 27 | do_compile() { |
| 28 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 29 | cpan_do_compile |
| 30 | } |
| 31 | |