Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager" |
| 2 | LICENSE = "GPLv3" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 4 | |
| 5 | DEPENDS = "bluez5 python3-pygobject python3-cython-native python3-setuptools-native intltool-native" |
| 6 | |
| 7 | inherit autotools systemd gsettings python3native gtk-icon-cache |
| 8 | |
| 9 | SRC_URI = " \ |
| 10 | https://github.com/blueman-project/blueman/releases/download/${PV}/blueman-${PV}.tar.xz \ |
| 11 | file://0001-Search-for-cython3.patch \ |
| 12 | " |
| 13 | SRC_URI[md5sum] = "9de89abb31be45bdbf11f7884764a2dc" |
| 14 | SRC_URI[sha256sum] = "f1eab2334e5a1587defa80900901048d14c2e8ffa8c0cff7240bc9937a61dbc3" |
| 15 | |
| 16 | EXTRA_OECONF = " \ |
| 17 | --disable-runtime-deps-check \ |
| 18 | --disable-schemas-compile \ |
| 19 | " |
| 20 | |
| 21 | SYSTEMD_SERVICE_${PN} = "${BPN}-mechanism.service" |
| 22 | SYSTEMD_AUTO_ENABLE_${PN} = "disable" |
| 23 | |
| 24 | RRECOMENDS_${PN} += "adwaita-icon-theme" |
| 25 | RDEPENDS_${PN} += " \ |
| 26 | python3-core \ |
| 27 | python3-dbus \ |
| 28 | packagegroup-tools-bluetooth \ |
| 29 | " |
| 30 | |
| 31 | PACKAGECONFIG ??= "thunar" |
| 32 | PACKAGECONFIG[thunar] = "--enable-thunar-sendto,--disable-thunar-sendto" |
| 33 | |
| 34 | FILES_${PN} += " \ |
| 35 | ${datadir}/dbus-1 \ |
| 36 | ${datadir}/Thunar \ |
| 37 | ${systemd_user_unitdir} \ |
| 38 | ${exec_prefix}${systemd_system_unitdir} \ |
| 39 | ${PYTHON_SITEPACKAGES_DIR} \ |
| 40 | " |
| 41 | |
| 42 | FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_blueman.a" |
| 43 | |
| 44 | # In code, path to python is a variable that is replaced with path to native version of it |
| 45 | # during the configure stage, e.g ../recipe-sysroot-native/usr/bin/python3-native/python3. |
| 46 | # Replace it with #!/usr/bin/env python3 |
| 47 | do_install_append() { |
| 48 | sed -i "1s/.*/#!\/usr\/bin\/env python3/" ${D}${prefix}/libexec/blueman-rfcomm-watcher \ |
| 49 | ${D}${prefix}/libexec/blueman-mechanism \ |
| 50 | ${D}${bindir}/blueman-tray \ |
| 51 | ${D}${bindir}/blueman-services \ |
| 52 | ${D}${bindir}/blueman-sendto \ |
| 53 | ${D}${bindir}/blueman-report \ |
| 54 | ${D}${bindir}/blueman-manager \ |
| 55 | ${D}${bindir}/blueman-assistant \ |
| 56 | ${D}${bindir}/blueman-applet \ |
| 57 | ${D}${bindir}/blueman-adapters |
| 58 | } |