Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | # Class for use to convert all CRLF line terminators to LF |
| 2 | # provided that some projects are being developed/maintained |
| 3 | # on Windows so they have different line terminators(CRLF) vs |
| 4 | # on Linux(LF), which can cause annoying patching errors during |
| 5 | # git push/checkout processes. |
| 6 | |
| 7 | do_convert_crlf_to_lf[depends] += "dos2unix-native:do_populate_sysroot" |
| 8 | |
| 9 | # Convert CRLF line terminators to LF |
| 10 | do_convert_crlf_to_lf () { |
| 11 | find ${S} -type f -exec dos2unix {} \; |
| 12 | } |
| 13 | |
| 14 | addtask convert_crlf_to_lf after do_unpack before do_patch |