Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Multipurpose relay for bidirectional data transfer" |
| 2 | DESCRIPTION = "Socat is a relay for bidirectional data \ |
| 3 | transfer between two independent data channels." |
| 4 | HOMEPAGE = "http://www.dest-unreach.org/socat/" |
| 5 | |
| 6 | SECTION = "console/network" |
| 7 | |
| 8 | DEPENDS = "openssl readline" |
| 9 | |
| 10 | LICENSE = "GPL-2.0+-with-OpenSSL-exception" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 12 | file://README;beginline=257;endline=287;md5=338c05eadd013872abb1d6e198e10a3f" |
| 13 | |
| 14 | |
| 15 | SRC_URI = "http://www.dest-unreach.org/socat/download/socat-${PV}.tar.bz2 \ |
| 16 | file://Makefile.in-fix-for-parallel-build.patch \ |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 17 | file://CVE-2016-2217.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | " |
| 19 | |
| 20 | SRC_URI[md5sum] = "b607edb65bc6c57f4a43f06247504274" |
| 21 | SRC_URI[sha256sum] = "0767e850c0329b9fdf711c6cd468565cbbb28786ba1a8a1cbd5531d4016b3e04" |
| 22 | |
| 23 | inherit autotools |
| 24 | |
| 25 | EXTRA_AUTORECONF += "--exclude=autoheader" |
| 26 | |
| 27 | EXTRA_OECONF += "ac_cv_have_z_modifier=yes sc_cv_sys_crdly_shift=9 \ |
| 28 | sc_cv_sys_tabdly_shift=11 sc_cv_sys_csize_shift=4 \ |
| 29 | ac_cv_ispeed_offset=13 \ |
| 30 | ac_cv_header_bsd_libutil_h=no \ |
| 31 | " |
| 32 | |
| 33 | PACKAGECONFIG ??= "tcp-wrappers" |
| 34 | PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers" |
| 35 | |
| 36 | do_install_prepend () { |
| 37 | mkdir -p ${D}${bindir} |
| 38 | install -d ${D}${bindir} ${D}${mandir}/man1 |
| 39 | } |