Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Command line file status display utility" |
| 2 | DESCRIPTION = "Displays all information about a file that the stat() call provides and all information about a filesystem that statfs() provides." |
| 3 | SECTION = "console/utils" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=39886b077fd072e876e5c4c16310b631 \ |
| 6 | file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 7 | |
| 8 | SRC_URI = "http://www.ibiblio.org/pub/Linux/utils/file/${BP}.tar.gz \ |
| 9 | file://fix-error-return.patch" |
| 10 | |
| 11 | SRC_URI[md5sum] = "37e247e8e400ad9205f1b0500b728fd3" |
| 12 | SRC_URI[sha256sum] = "7071f0384a423a938dd542c1f08547a02824f6359acd3ef3f944b2c4c2d1ee09" |
| 13 | |
| 14 | do_install() { |
| 15 | install -d ${D}${base_bindir} ${D}${mandir}/man1 |
| 16 | install -m 755 stat ${D}${base_bindir}/stat.stat |
| 17 | install -m 644 stat.1 ${D}${mandir}/man1 |
| 18 | } |
| 19 | |
| 20 | inherit update-alternatives |
| 21 | |
| 22 | ALTERNATIVE_${PN} = "stat" |
| 23 | ALTERNATIVE_PRIORITY[stat] = "200" |
| 24 | ALTERNATIVE_LINK_NAME[stat] = "${base_bindir}/stat" |
| 25 | ALTERNATIVE_TARGET[stat] = "${base_bindir}/stat.stat" |
| 26 | |
| 27 | ALTERNATIVE_${PN}-doc = "stat.1" |
| 28 | ALTERNATIVE_LINK_NAME[stat.1] = "${mandir}/man1/stat.1" |
| 29 | |
| 30 | BBCLASSEXTEND = "native" |
| 31 | |