Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require xorg-driver-video.inc |
| 2 | |
| 3 | SUMMARY = "X.Org X server -- Texas Instruments OMAP framebuffer driver" |
| 4 | |
| 5 | SUMMARY = "X.Org X server -- TI OMAP integrated graphics chipsets driver" |
| 6 | |
| 7 | DESCRIPTION = "Open-source X.org graphics driver for TI OMAP graphics \ |
| 8 | Currently relies on a closed-source submodule for EXA acceleration on \ |
| 9 | the following chipsets: \ |
| 10 | + OMAP3430 \ |
| 11 | + OMAP3630 \ |
| 12 | + OMAP4430 \ |
| 13 | + OMAP4460 \ |
| 14 | + OMAP5430 \ |
| 15 | + OMAP5432 \ |
| 16 | \ |
| 17 | NOTE: this driver is work in progress.. you probably don't want to try \ |
| 18 | and use it yet. The API/ABI between driver and kernel, and driver and \ |
| 19 | acceleration submodules is not stable yet. This driver requires the \ |
| 20 | omapdrm kernel driver w/ GEM support. \ |
| 21 | " |
| 22 | |
| 23 | LICENSE = "GPLv2+" |
| 24 | LIC_FILES_CHKSUM = "file://COPYING;md5=10ce5de3b111315ea652a5f74ec0c602" |
| 25 | DEPENDS += "virtual/libx11 libdrm xf86driproto" |
| 26 | |
| 27 | SRC_URI += "file://0001-drmmode_output_dpms-Replace-logical-with-bitwise-ope.patch" |
| 28 | |
| 29 | SRC_URI[md5sum] = "be35daf6fa4b75092cc4a8978c437bc5" |
| 30 | SRC_URI[sha256sum] = "db1e0e69fd4c4c8fdca5ef2cb0447bccd7518a718495876a6904bef57b39986d" |
| 31 | |
| 32 | CFLAGS += " -I${STAGING_INCDIR}/xorg " |
| 33 | |
| 34 | # Use overlay 2 on omap3 to enable other apps to use overlay 1 (e.g. dmai or omapfbplay) |
| 35 | do_compile_prepend_armv7a () { |
| 36 | sed -i -e s:fb1:fb2:g ${S}/src/omap_xv.c |
| 37 | } |
| 38 | |
| 39 | python () { |
| 40 | if not bb.utils.contains ('DISTRO_FEATURES', 'opengl', True, False, d): |
| 41 | raise bb.parse.SkipPackage("'opengl' not in DISTRO_FEATURES") |
| 42 | } |
| 43 | |