Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "High-level GnuPG encryption/signing API" |
| 2 | DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management" |
| 3 | HOMEPAGE = "http://www.gnupg.org/gpgme.html" |
| 4 | BUGTRACKER = "https://bugs.g10code.com/gnupg/index" |
| 5 | |
| 6 | LICENSE = "GPLv2+ & LGPLv2.1+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 8 | file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \ |
| 9 | file://src/gpgme.h.in;endline=23;md5=71ba2ae8d6ca034ed10bd099a8cf473c \ |
| 10 | file://src/engine.h;endline=22;md5=4b6d8ba313d9b564cc4d4cfb1640af9d" |
| 11 | |
| 12 | SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/${BP}.tar.bz2 \ |
| 13 | file://gpgme.pc \ |
| 14 | file://pkgconfig.patch \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "feafa03ea064e1d1dc11bc2b88404623" |
| 18 | SRC_URI[sha256sum] = "bb38c0ec8815c9e94e6047b484984808a8dad9d6bec8df33dc5339fd55ffea6c" |
| 19 | |
| 20 | DEPENDS = "libgpg-error libassuan" |
| 21 | |
| 22 | BINCONFIG = "${bindir}/gpgme-config" |
| 23 | |
| 24 | inherit autotools texinfo binconfig-disabled pkgconfig |
| 25 | |
| 26 | PACKAGES =+ "${PN}-pthread" |
| 27 | FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*" |
| 28 | FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/*" |
| 29 | |
| 30 | do_configure_prepend () { |
| 31 | # Else these could be used in preference to those in aclocal-copy |
| 32 | rm -f ${S}/m4/gpg-error.m4 |
| 33 | rm -f ${S}/m4/libassuan.m4 |
| 34 | } |
| 35 | |
| 36 | do_install_append () { |
| 37 | install -d ${D}${libdir}/pkgconfig |
| 38 | install -m 0644 ${WORKDIR}/gpgme.pc ${D}${libdir}/pkgconfig/ |
| 39 | } |