Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Userspace library to access USB (version 1.0)" |
| 2 | HOMEPAGE = "http://libusb.sf.net" |
| 3 | BUGTRACKER = "http://www.libusb.org/report" |
| 4 | SECTION = "libs" |
| 5 | |
| 6 | LICENSE = "LGPLv2.1+" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" |
| 8 | |
| 9 | BBCLASSEXTEND = "native nativesdk" |
| 10 | |
| 11 | SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-${PV}.tar.bz2 \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI[md5sum] = "f9e2bb5879968467e5ca756cb4e1fa7e" |
| 15 | SRC_URI[sha256sum] = "6c502c816002f90d4f76050a6429c3a7e0d84204222cbff2dce95dd773ba6840" |
| 16 | |
| 17 | S = "${WORKDIR}/libusb-${PV}" |
| 18 | |
| 19 | inherit autotools pkgconfig |
| 20 | |
| 21 | # Don't configure udev by default since it will cause a circular |
| 22 | # dependecy with udev package, which depends on libusb |
| 23 | EXTRA_OECONF = "--libdir=${base_libdir} --disable-udev" |
| 24 | |
| 25 | do_install_append() { |
| 26 | install -d ${D}${libdir} |
| 27 | if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then |
| 28 | mv ${D}${base_libdir}/pkgconfig ${D}${libdir} |
| 29 | fi |
| 30 | } |
| 31 | |
| 32 | FILES_${PN} += "${base_libdir}/*.so.*" |
| 33 | |
| 34 | FILES_${PN}-dev += "${base_libdir}/*.so ${base_libdir}/*.la" |